aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-09-01 02:00:00 +0200
commita1aed6f159f661629ffe3530f3e6b2c344df219f (patch)
treee7e143a9e3400fcc0ba6a918de90f3a5f95f73c6 /gnu/packages/file-systems.scm
parent333885f613f5f2a0a991b8865c98122e4970b67d (diff)
downloadguix-a1aed6f159f661629ffe3530f3e6b2c344df219f.tar
guix-a1aed6f159f661629ffe3530f3e6b2c344df219f.tar.gz
gnu: bcachefs-static: Consistently inherit bcachefs-tools/static.
* gnu/packages/file-systems.scm (bcachefs/static)[version, home-page, license]: Inherit bcachefs-tools/static. Change-Id: Idc3b3e3538876b55dc9e27912c976f5d03cc95cb
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index c57b72a27f..c40c30f5b3 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -715,7 +715,7 @@ performance and other characteristics.")
(define-public bcachefs/static
(package
(name "bcachefs-static")
- (version (package-version bcachefs-tools))
+ (version (package-version bcachefs-tools/static))
(source #f)
(build-system trivial-build-system)
(arguments
@@ -733,11 +733,12 @@ performance and other characteristics.")
(invoke "sbin/bcachefs" "version"))))) ; test suite
(inputs
(list bcachefs-tools/static))
- (home-page (package-home-page bcachefs-tools))
+ (home-page (package-home-page bcachefs-tools/static))
(synopsis "Statically-linked bcachefs command from bcachefs-tools")
- (description "This package provides the statically-linked @command{bcachefs}
-from the bcachefs-tools package. It is meant to be used in initrds.")
- (license (package-license bcachefs-tools))))
+ (description
+ "This package provides the statically-linked @command{bcachefs} from the
+bcachefs-tools package. It is meant to be used in initrds.")
+ (license (package-license bcachefs-tools/static))))
(define-public exfatprogs
(package