aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 15:56:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:59 +0200
commitbcbf703111a809349bffc65a83a755a7427af444 (patch)
tree57e1f52029209e4db38c7b336deeecbcebef53b1 /gnu/packages/crates-crypto.scm
parent5fb3d4f758b2ca386cab3b8782cd61da60511f0c (diff)
downloadguix-bcbf703111a809349bffc65a83a755a7427af444.tar
guix-bcbf703111a809349bffc65a83a755a7427af444.tar.gz
gnu: rust-poly1305: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-poly1305-0.8, rust-poly1305-0.7): Move from here ... * gnu/packages/crates-crypto.scm: ... to here. Change-Id: I3c2d8a5714b37c90acf04f801a755bc42431c18e
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 2670aa7706..81a0c27986 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -2460,6 +2460,56 @@ implementation suitable for use with cryptographic private keys.")
`(#:skip-build? #t
#:cargo-inputs (("rust-base64ct" ,rust-base64ct-1))))))
+(define-public rust-poly1305-0.8
+ (package
+ (name "rust-poly1305")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "poly1305" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1grs77skh7d8vi61ji44i8gpzs3r9x7vay50i6cg8baxfa8bsnc1"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-cpufeatures" ,rust-cpufeatures-0.2)
+ ("rust-opaque-debug" ,rust-opaque-debug-0.3)
+ ("rust-universal-hash" ,rust-universal-hash-0.5)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs (("rust-hex-literal" ,rust-hex-literal-0.3))))
+ (home-page "https://github.com/RustCrypto/universal-hashes")
+ (synopsis "Poly1305 universal hash")
+ (description
+ "Poly1305 is a universal hash function which, when combined with
+a cipher, can be used as a Message Authentication Code (MAC).")
+ (license (list license:asl2.0 license:expat))))
+
+(define-public rust-poly1305-0.7
+ (package
+ (inherit rust-poly1305-0.8)
+ (name "rust-poly1305")
+ (version "0.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "poly1305" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1pkf4jlriskq9rvz8y5fjj9dw42q6yg5djijlin4n6p1dd3yp2h4"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin (substitute* "Cargo.toml"
+ (("version = \">=1, <1\\.4\"") "version = \"^1\""))))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-cpufeatures" ,rust-cpufeatures-0.2)
+ ("rust-opaque-debug" ,rust-opaque-debug-0.3)
+ ("rust-universal-hash" ,rust-universal-hash-0.4)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs
+ (("rust-hex-literal" ,rust-hex-literal-0.3))))))
+
(define-public rust-ppv-lite86-0.2
(package
(name "rust-ppv-lite86")