aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-crypto.scm50
-rw-r--r--gnu/packages/crates-io.scm50
2 files changed, 50 insertions, 50 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 2670aa7706..81a0c27986 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -2460,6 +2460,56 @@ implementation suitable for use with cryptographic private keys.")
`(#:skip-build? #t
#:cargo-inputs (("rust-base64ct" ,rust-base64ct-1))))))
+(define-public rust-poly1305-0.8
+ (package
+ (name "rust-poly1305")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "poly1305" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1grs77skh7d8vi61ji44i8gpzs3r9x7vay50i6cg8baxfa8bsnc1"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-cpufeatures" ,rust-cpufeatures-0.2)
+ ("rust-opaque-debug" ,rust-opaque-debug-0.3)
+ ("rust-universal-hash" ,rust-universal-hash-0.5)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs (("rust-hex-literal" ,rust-hex-literal-0.3))))
+ (home-page "https://github.com/RustCrypto/universal-hashes")
+ (synopsis "Poly1305 universal hash")
+ (description
+ "Poly1305 is a universal hash function which, when combined with
+a cipher, can be used as a Message Authentication Code (MAC).")
+ (license (list license:asl2.0 license:expat))))
+
+(define-public rust-poly1305-0.7
+ (package
+ (inherit rust-poly1305-0.8)
+ (name "rust-poly1305")
+ (version "0.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "poly1305" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1pkf4jlriskq9rvz8y5fjj9dw42q6yg5djijlin4n6p1dd3yp2h4"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin (substitute* "Cargo.toml"
+ (("version = \">=1, <1\\.4\"") "version = \"^1\""))))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-cpufeatures" ,rust-cpufeatures-0.2)
+ ("rust-opaque-debug" ,rust-opaque-debug-0.3)
+ ("rust-universal-hash" ,rust-universal-hash-0.4)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs
+ (("rust-hex-literal" ,rust-hex-literal-0.3))))))
+
(define-public rust-ppv-lite86-0.2
(package
(name "rust-ppv-lite86")
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cdd79c26a6..bbc919f5b0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -49673,56 +49673,6 @@ library.")
(description "Proc-macro crate for pollster.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-poly1305-0.8
- (package
- (name "rust-poly1305")
- (version "0.8.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "poly1305" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1grs77skh7d8vi61ji44i8gpzs3r9x7vay50i6cg8baxfa8bsnc1"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs (("rust-cpufeatures" ,rust-cpufeatures-0.2)
- ("rust-opaque-debug" ,rust-opaque-debug-0.3)
- ("rust-universal-hash" ,rust-universal-hash-0.5)
- ("rust-zeroize" ,rust-zeroize-1))
- #:cargo-development-inputs (("rust-hex-literal" ,rust-hex-literal-0.3))))
- (home-page "https://github.com/RustCrypto/universal-hashes")
- (synopsis "Poly1305 universal hash")
- (description
- "Poly1305 is a universal hash function which, when combined with
-a cipher, can be used as a Message Authentication Code (MAC).")
- (license (list license:asl2.0 license:expat))))
-
-(define-public rust-poly1305-0.7
- (package
- (inherit rust-poly1305-0.8)
- (name "rust-poly1305")
- (version "0.7.2")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "poly1305" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1pkf4jlriskq9rvz8y5fjj9dw42q6yg5djijlin4n6p1dd3yp2h4"))
- (modules '((guix build utils)))
- (snippet
- '(begin (substitute* "Cargo.toml"
- (("version = \">=1, <1\\.4\"") "version = \"^1\""))))))
- (arguments
- `(#:cargo-inputs
- (("rust-cpufeatures" ,rust-cpufeatures-0.2)
- ("rust-opaque-debug" ,rust-opaque-debug-0.3)
- ("rust-universal-hash" ,rust-universal-hash-0.4)
- ("rust-zeroize" ,rust-zeroize-1))
- #:cargo-development-inputs
- (("rust-hex-literal" ,rust-hex-literal-0.3))))))
-
(define-public rust-polyval-0.6
(package
(name "rust-polyval")