aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-28 17:47:19 +0200
committerLudovic Courtès <ludo@gnu.org>2017-08-02 00:03:59 +0200
commit7441f1dbd77b09f6170858795bc7deea6280b972 (patch)
tree3566cd586e306420baadbee2e2cb3387976a8177 /configure.ac
parentfc8f0631b4163d31a97fccb9a14201b5e861fa52 (diff)
downloadguix-7441f1dbd77b09f6170858795bc7deea6280b972.tar
guix-7441f1dbd77b09f6170858795bc7deea6280b972.tar.gz
build: Make Guile-Git a hard requirement.
* configure.ac: Error out when (git) is missing. * doc/guix.texi (Requirements): Mention Guile-Git. * Makefile.am (MODULES): Add guix/git.scm unconditionally.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2b75c900cc..9ad7598f8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,14 +100,16 @@ if test "x$have_gnutls" != "xyes"; then
AC_MSG_ERROR([The Guile bindings of GnuTLS are missing; please install them.])
fi
+dnl Check for Guile-Git.
+GUILE_MODULE_AVAILABLE([have_guile_git], [(git)])
+if test "x$have_guile_git" != "xyes"; then
+ AC_MSG_ERROR([Guile-Git is missing; please install it.])
+fi
+
dnl Guile-JSON is used in various places.
GUILE_MODULE_AVAILABLE([have_guile_json], [(json)])
AM_CONDITIONAL([HAVE_GUILE_JSON], [test "x$have_guile_json" = "xyes"])
-dnl Check for Guile-Git.
-GUILE_MODULE_AVAILABLE([have_guile_git], [(git)])
-AM_CONDITIONAL([HAVE_GUILE_GIT], [test "x$have_guile_git" = "xyes"])
-
dnl Make sure we have a full-fledged Guile.
GUIX_ASSERT_GUILE_FEATURES([regex posix socket net-db threads])