aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-28 17:47:19 +0200
committerLudovic Courtès <ludo@gnu.org>2017-08-02 00:03:59 +0200
commit7441f1dbd77b09f6170858795bc7deea6280b972 (patch)
tree3566cd586e306420baadbee2e2cb3387976a8177
parentfc8f0631b4163d31a97fccb9a14201b5e861fa52 (diff)
downloadguix-7441f1dbd77b09f6170858795bc7deea6280b972.tar
guix-7441f1dbd77b09f6170858795bc7deea6280b972.tar.gz
build: Make Guile-Git a hard requirement.
* configure.ac: Error out when (git) is missing. * doc/guix.texi (Requirements): Mention Guile-Git. * Makefile.am (MODULES): Add guix/git.scm unconditionally.
-rw-r--r--Makefile.am8
-rw-r--r--configure.ac10
-rw-r--r--doc/guix.texi4
3 files changed, 11 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 5888bc0266..0a7e375c29 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,6 +66,7 @@ MODULES = \
guix/gnu-maintenance.scm \
guix/upstream.scm \
guix/licenses.scm \
+ guix/git.scm \
guix/graph.scm \
guix/cache.scm \
guix/cve.scm \
@@ -207,13 +208,6 @@ MODULES += \
endif HAVE_GUILE_SSH
-if HAVE_GUILE_GIT
-
-MODULES += \
- guix/git.scm
-
-endif HAVE_GUILE_GIT
-
if BUILD_DAEMON_OFFLOAD
MODULES += \
diff --git a/configure.ac b/configure.ac
index 2b75c900cc..9ad7598f8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,14 +100,16 @@ if test "x$have_gnutls" != "xyes"; then
AC_MSG_ERROR([The Guile bindings of GnuTLS are missing; please install them.])
fi
+dnl Check for Guile-Git.
+GUILE_MODULE_AVAILABLE([have_guile_git], [(git)])
+if test "x$have_guile_git" != "xyes"; then
+ AC_MSG_ERROR([Guile-Git is missing; please install it.])
+fi
+
dnl Guile-JSON is used in various places.
GUILE_MODULE_AVAILABLE([have_guile_json], [(json)])
AM_CONDITIONAL([HAVE_GUILE_JSON], [test "x$have_guile_json" = "xyes"])
-dnl Check for Guile-Git.
-GUILE_MODULE_AVAILABLE([have_guile_git], [(git)])
-AM_CONDITIONAL([HAVE_GUILE_GIT], [test "x$have_guile_git" = "xyes"])
-
dnl Make sure we have a full-fledged Guile.
GUIX_ASSERT_GUILE_FEATURES([regex posix socket net-db threads])
diff --git a/doc/guix.texi b/doc/guix.texi
index 6b4b19d0cf..7957565e85 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -580,6 +580,10 @@ later, including 2.2.x;
@uref{http://gnutls.org/, GnuTLS}, specifically its Guile bindings
(@pxref{Guile Preparations, how to install the GnuTLS bindings for
Guile,, gnutls-guile, GnuTLS-Guile});
+@item
+@c FIXME: Specify a version number once a release has been made.
+@uref{https://gitlab.com/guile-git/guile-git, Guile-Git}, from August
+2017 or later;
@item @url{http://www.gnu.org/software/make/, GNU Make}.
@end itemize