aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:05:04 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:10:56 +0100
commitcddf767eed7322fb94c1ff31b2ba9613b28ad2b7 (patch)
tree83b18975ab181b3ca114d24c5642fd38dc18387a
parentb3a0e3ea37d61f1e7fc529adb6eef62ddc89338d (diff)
downloadguix-cddf767eed7322fb94c1ff31b2ba9613b28ad2b7.tar
guix-cddf767eed7322fb94c1ff31b2ba9613b28ad2b7.tar.gz
gnu: Remove ocaml4.07-ppx-js-style.
* gnu/packages/ocaml.scm (ocaml4.07-ppx-js-style): Remove variable. (ocaml-ppx-js-style)[properties]: Remove variant. Change-Id: I2243b4ae20136fb3d91c578d9bb2eeea306b0bb1
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index bbcf97ccb0..407a46d15d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7436,8 +7436,7 @@ to denote the expected output.")
(arguments `(#:tests? #f)) ; No tests
(propagated-inputs
(list ocaml-base ocaml-migrate-parsetree ocaml-octavius ocaml-ppxlib))
- (properties `((upstream-name . "ppx_js_style")
- (ocaml4.07-variant . ,(delay ocaml4.07-ppx-js-style))))
+ (properties `((upstream-name . "ppx_js_style")))
(home-page "https://github.com/janestreet/ppx_js_style")
(synopsis "Code style checker for Jane Street Packages")
(description "This package is a no-op ppx rewriter. It is used as a
@@ -7445,16 +7444,6 @@ to denote the expected output.")
packages.")
(license license:asl2.0)))
-(define-public ocaml4.07-ppx-js-style
- (package-with-ocaml4.07
- (package
- (inherit ocaml-ppx-js-style)
- (version "0.11.0")
- (source
- (janestreet-origin "ppx_js_style" version
- "0z3fc55jdjhhsblla6z4fqc13kljpcz29q79rvs5h2vsraqrldr2"))
- (properties `((upstream-name . "ppx_js_style"))))))
-
(define-public ocaml-ppx-typerep-conv
(package
(name "ocaml-ppx-typerep-conv")