aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index bbcf97ccb0..407a46d15d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7436,8 +7436,7 @@ to denote the expected output.")
(arguments `(#:tests? #f)) ; No tests
(propagated-inputs
(list ocaml-base ocaml-migrate-parsetree ocaml-octavius ocaml-ppxlib))
- (properties `((upstream-name . "ppx_js_style")
- (ocaml4.07-variant . ,(delay ocaml4.07-ppx-js-style))))
+ (properties `((upstream-name . "ppx_js_style")))
(home-page "https://github.com/janestreet/ppx_js_style")
(synopsis "Code style checker for Jane Street Packages")
(description "This package is a no-op ppx rewriter. It is used as a
@@ -7445,16 +7444,6 @@ to denote the expected output.")
packages.")
(license license:asl2.0)))
-(define-public ocaml4.07-ppx-js-style
- (package-with-ocaml4.07
- (package
- (inherit ocaml-ppx-js-style)
- (version "0.11.0")
- (source
- (janestreet-origin "ppx_js_style" version
- "0z3fc55jdjhhsblla6z4fqc13kljpcz29q79rvs5h2vsraqrldr2"))
- (properties `((upstream-name . "ppx_js_style"))))))
-
(define-public ocaml-ppx-typerep-conv
(package
(name "ocaml-ppx-typerep-conv")