aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-25 21:01:32 +0200
committerMarius Bakke <marius@gnu.org>2022-06-26 12:06:27 +0200
commitbf99d1be2ff5ba368350a7a30419120f0b170cdf (patch)
tree560a5a85e66ce36ea3da82dbc1b4f945c6599af8
parent97fb977eb8d570f05adc5740af5e12fb740cc91c (diff)
downloadguix-bf99d1be2ff5ba368350a7a30419120f0b170cdf.tar
guix-bf99d1be2ff5ba368350a7a30419120f0b170cdf.tar.gz
gnu: coreutils: Update to 9.1.
* gnu/packages/base.scm (coreutils): Update to 9.1. [source](patches): Remove. * gnu/packages/commencement.scm (coreutils-mesboot)[native-inputs]: Add SED-MESBOOT. * gnu/packages/patches/coreutils-ls.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/base.scm6
-rw-r--r--gnu/packages/commencement.scm10
-rw-r--r--gnu/packages/patches/coreutils-ls.patch117
4 files changed, 11 insertions, 123 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a0c9fe35b7..540bd81372 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -969,7 +969,6 @@ dist_patch_DATA = \
%D%/packages/patches/cool-retro-term-wctype.patch \
%D%/packages/patches/coreutils-gnulib-tests.patch \
%D%/packages/patches/coq-fix-envvars.patch \
- %D%/packages/patches/coreutils-ls.patch \
%D%/packages/patches/cpuinfo-system-libraries.patch \
%D%/packages/patches/cpulimit-with-glib-2.32.patch \
%D%/packages/patches/crawl-upgrade-saves.patch \
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 33db96974f..b3c4ed27a5 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -328,16 +328,14 @@ used to apply commands with arbitrarily long arguments.")
(define-public coreutils
(package
(name "coreutils")
- (version "8.32")
+ (version "9.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/coreutils/coreutils-"
version ".tar.xz"))
(sha256
(base32
- "1yjcrh5hw70c0yn8zw55pd6j51dj90anpq8mmg649ps9g3gdhn24"))
- (patches (search-patches "coreutils-ls.patch"
- "coreutils-gnulib-tests.patch"))))
+ "08q4b0w7mwfxbqjs712l6wrwl2ijs7k50kssgbryg9wbsw8g98b1"))))
(build-system gnu-build-system)
(inputs `(,acl ;TODO: add SELinux
,attr ;for xattrs in ls, mv, etc
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index eff396b911..19db0def4e 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1838,10 +1838,18 @@ exec " gcc "/bin/" program
;; In the future, Gash et al. could handle it directly, but it's not
;; ready yet.
(define bash-mesboot (mesboot-package "bash-mesboot" static-bash))
-(define coreutils-mesboot (mesboot-package "coreutils-mesboot" coreutils))
(define grep-mesboot (mesboot-package "grep-mesboot" grep))
(define sed-mesboot (mesboot-package "sed-mesboot" sed))
+;; "sed" from Gash-Utils lacks the 'w' command as of 0.2.0.
+(define coreutils-mesboot
+ (let ((pkg (mesboot-package "coreutils-mesboot" coreutils)))
+ (package
+ (inherit pkg)
+ (native-inputs
+ `(("sed" ,sed-mesboot)
+ ,@(package-native-inputs pkg))))))
+
;; The XZ implementation in Bootar cannot decompress 'tar'.
(define xz-mesboot
(let ((pkg (mesboot-package "xz-mesboot" xz)))
diff --git a/gnu/packages/patches/coreutils-ls.patch b/gnu/packages/patches/coreutils-ls.patch
deleted file mode 100644
index 59cbbf00b5..0000000000
--- a/gnu/packages/patches/coreutils-ls.patch
+++ /dev/null
@@ -1,117 +0,0 @@
-Patch taken from upstream to fix cross-compilation for aarch64. This can be
-removed on the next coreutils release.
-
-From 10fcb97bd728f09d4a027eddf8ad2900f0819b0a Mon Sep 17 00:00:00 2001
-From: Paul Eggert <eggert@cs.ucla.edu>
-Date: Thu, 5 Mar 2020 17:25:29 -0800
-Subject: [PATCH] ls: restore 8.31 behavior on removed directories
-
-* NEWS: Mention this.
-* src/ls.c: Do not include <sys/sycall.h>
-(print_dir): Don't worry about whether the directory is removed.
-* tests/ls/removed-directory.sh: Adjust to match new (i.e., old)
-behavior.
----
- NEWS | 6 ++++++
- src/ls.c | 22 ----------------------
- tests/ls/removed-directory.sh | 10 ++--------
- 3 files changed, 8 insertions(+), 30 deletions(-)
-
-diff --git a/NEWS b/NEWS
-index fdc8bf5db..653e7178b 100644
---- a/NEWS
-+++ b/NEWS
-@@ -2,6 +2,12 @@ GNU coreutils NEWS -*- outline -*-
-
- * Noteworthy changes in release ?.? (????-??-??) [?]
-
-+** Changes in behavior
-+
-+ On GNU/Linux systems, ls no longer issues an error message on
-+ directory merely because it was removed. This reverts a change
-+ that was made in release 8.32.
-+
-
- * Noteworthy changes in release 8.32 (2020-03-05) [stable]
-
-diff --git a/src/ls.c b/src/ls.c
-index 24b983287..4acf5f44d 100644
---- a/src/ls.c
-+++ b/src/ls.c
-@@ -49,10 +49,6 @@
- # include <sys/ptem.h>
- #endif
-
--#ifdef __linux__
--# include <sys/syscall.h>
--#endif
--
- #include <stdio.h>
- #include <assert.h>
- #include <setjmp.h>
-@@ -2896,7 +2892,6 @@ print_dir (char const *name, char const *realname, bool command_line_arg)
- struct dirent *next;
- uintmax_t total_blocks = 0;
- static bool first = true;
-- bool found_any_entries = false;
-
- errno = 0;
- dirp = opendir (name);
-@@ -2972,7 +2967,6 @@ print_dir (char const *name, char const *realname, bool command_line_arg)
- next = readdir (dirp);
- if (next)
- {
-- found_any_entries = true;
- if (! file_ignored (next->d_name))
- {
- enum filetype type = unknown;
-@@ -3018,22 +3012,6 @@ print_dir (char const *name, char const *realname, bool command_line_arg)
- if (errno != EOVERFLOW)
- break;
- }
--#ifdef __linux__
-- else if (! found_any_entries)
-- {
-- /* If readdir finds no directory entries at all, not even "." or
-- "..", then double check that the directory exists. */
-- if (syscall (SYS_getdents, dirfd (dirp), NULL, 0) == -1
-- && errno != EINVAL)
-- {
-- /* We exclude EINVAL as that pertains to buffer handling,
-- and we've passed NULL as the buffer for simplicity.
-- ENOENT is returned if appropriate before buffer handling. */
-- file_failure (command_line_arg, _("reading directory %s"), name);
-- }
-- break;
-- }
--#endif
- else
- break;
-
-diff --git a/tests/ls/removed-directory.sh b/tests/ls/removed-directory.sh
-index e8c835dab..fe8f929a1 100755
---- a/tests/ls/removed-directory.sh
-+++ b/tests/ls/removed-directory.sh
-@@ -26,20 +26,14 @@ case $host_triplet in
- *) skip_ 'non linux kernel' ;;
- esac
-
--LS_FAILURE=2
--
--cat <<\EOF >exp-err || framework_failure_
--ls: reading directory '.': No such file or directory
--EOF
--
- cwd=$(pwd)
- mkdir d || framework_failure_
- cd d || framework_failure_
- rmdir ../d || framework_failure_
-
--returns_ $LS_FAILURE ls >../out 2>../err || fail=1
-+ls >../out 2>../err || fail=1
- cd "$cwd" || framework_failure_
- compare /dev/null out || fail=1
--compare exp-err err || fail=1
-+compare /dev/null err || fail=1
-
- Exit $fail