aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-25 20:59:01 +0200
committerMarius Bakke <marius@gnu.org>2022-06-26 12:06:27 +0200
commit97fb977eb8d570f05adc5740af5e12fb740cc91c (patch)
tree1521786b54908e0926254275a2557c794e4c8583
parente15e7b226cabaeac171e20f2a45249cce4c2c12b (diff)
downloadguix-97fb977eb8d570f05adc5740af5e12fb740cc91c.tar
guix-97fb977eb8d570f05adc5740af5e12fb740cc91c.tar.gz
gnu: linux-libre-headers: Update to 5.15.49.
* gnu/packages/linux.scm (linux-libre-headers-5.10.35): Replace with ... (linux-libre-headers-5.15.49): This new variable. (linux-libre-headers): Adjust accordingly. * gnu/packages/commencement.scm (linux-libre-headers-boot0)[arguments]: Add phase to lower toolchain requirements.
-rw-r--r--gnu/packages/commencement.scm15
-rw-r--r--gnu/packages/linux.scm8
2 files changed, 17 insertions, 6 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 5b7a697b1f..eff396b911 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2017, 2018, 2019, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019, 2020, 2021, 2022 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
-;;; Copyright © 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2019-2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020, 2022 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -2486,7 +2486,18 @@ memoized as a function of '%current-system'."
(arguments
`(#:guile ,%bootstrap-guile
#:implicit-inputs? #f
- ,@(package-arguments linux-libre-headers)))
+ ,@(substitute-keyword-arguments (package-arguments linux-libre-headers)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'lower-version-requirements
+ (lambda _
+ ;; Pacify version checks so it works with the bootstrap
+ ;; toolchain, since we are not building the full kernel.
+ (substitute* "scripts/min-tool-version.sh"
+ (("echo 5\\.1\\.0") ;GCC
+ "echo 4.9.4")
+ (("echo 2\\.23\\.0") ;binutils
+ "echo 2.20.1")))))))))
(native-inputs
`(("perl" ,perl-boot0)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e17e1ef42d..2fd813c5b7 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -639,11 +639,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The following package is used in the early bootstrap, and thus must be kept
;; stable and with minimal build requirements.
-(define-public linux-libre-headers-5.10.35
- (make-linux-libre-headers "5.10.35" "gnu"
- "0q2rnchad55d49f3rajrkazz0fcjv1irwrdb1hwjnl01fzm2gjk3"))
+(define-public linux-libre-headers-5.15.49
+ (make-linux-libre-headers "5.15.49" "gnu"
+ "13zqdcm4664vh7g57sxbfrlpsxm7zrma72mxdfdz7d9yndy2gfv8"))
-(define-public linux-libre-headers linux-libre-headers-5.10.35)
+(define-public linux-libre-headers linux-libre-headers-5.15.49)
;;;