aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2024-10-30 18:08:45 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-11-01 12:11:45 +0100
commita18b8a4a9225aecda922d457c3e77486393d7743 (patch)
tree8e7f33fabe3b5d9021ec4d3d2057df43cc94aad8
parente96af11f2b524a8ded2307987cb21393eb724d90 (diff)
downloadguix-a18b8a4a9225aecda922d457c3e77486393d7743.tar
guix-a18b8a4a9225aecda922d457c3e77486393d7743.tar.gz
gnu: Add r-robustrankaggreg.
* gnu/packages/cran.scm (r-robustrankaggreg): New variable. Change-Id: I2dbc983544b9858e279c192f00d52b3f18bc71c4 Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c221bb3d46..1a2c100ee7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1629,6 +1629,28 @@ matrix decomposition, sparse principal components analysis, and sparse
canonical correlation analysis.")
(license license:gpl2+)))
+(define-public r-robustrankaggreg
+ (package
+ (name "r-robustrankaggreg")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RobustRankAggreg" version))
+ (sha256
+ (base32 "0p2nbgxv2132gcyx7zq2gzl6ipsxndx64i7y8v9nh5awcdy8v44p"))))
+ (properties `((upstream-name . "RobustRankAggreg")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/package=RobustRankAggreg")
+ (synopsis "Methods for robust rank aggregation")
+ (description
+ "This tool provides methods for aggregating ranked lists, especially
+lists of genes. It implements the Robust Rank Aggregation and other simple
+algorithms for the task. RRA method uses a probabilistic model for
+aggregation that is robust to noise and also facilitates the calculation of
+significance probabilities for all the elements in the final ranking.")
+ (license license:gpl2)))
+
(define-public r-rpresto
(package
(name "r-rpresto")