aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAfkhami, Navid <Navid.Afkhami@mdc-berlin.de>2024-09-26 10:37:18 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-11-01 12:10:30 +0100
commite96af11f2b524a8ded2307987cb21393eb724d90 (patch)
treef8dda185213c1fa85c278ff4d9f9724deeae2170
parentaa7511eeb41b17de3c3eae96fcd0d68d1b374b3b (diff)
downloadguix-e96af11f2b524a8ded2307987cb21393eb724d90.tar
guix-e96af11f2b524a8ded2307987cb21393eb724d90.tar.gz
gnu: Add r-cellchat-2.
* gnu/packages/bioinformatics.scm (r-cellchat-2): New variable. Change-Id: Iae15f373aefa1c2a0899d5271cf8dddbbfdfa2bd
-rw-r--r--gnu/packages/bioinformatics.scm66
1 files changed, 66 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e0e8ce81b9..1cfcc4aa56 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14342,6 +14342,72 @@ droplet sequencing. It has been particularly tailored for Drop-seq.")
communication networks from scRNA-seq data.")
(license license:gpl3))))
+(define-public r-cellchat-2
+ (let ((commit "b05405af0f4f2cac99f2211e888d42de4c5a9d59")
+ (revision "1"))
+ (package
+ (name "r-cellchat")
+ (version (git-version "2.1.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jinworks/CellChat")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14s7bl70xi21ivqr1c3qx6kjf1ndlyxag880xldqkfsqpksvyvkc"))
+ (snippet '(for-each delete-file
+ '("src/CellChat.so" "src/CellChat_Rcpp.o"
+ "src/RcppExports.o")))))
+ (properties `((upstream-name . "CellChat")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biocgenerics
+ r-biocneighbors
+ r-bslib
+ r-circlize
+ r-colorspace
+ r-complexheatmap
+ r-cowplot
+ r-dplyr
+ r-fnn
+ r-future
+ r-future-apply
+ r-ggalluvial
+ r-ggnetwork
+ r-ggplot2
+ r-ggpubr
+ r-ggrepel
+ r-igraph
+ r-irlba
+ r-magrittr
+ r-matrix
+ r-nmf
+ r-patchwork
+ r-pbapply
+ r-plotly
+ r-plyr
+ r-rcolorbrewer
+ r-rcpp
+ r-rcppeigen
+ r-reshape2
+ r-reticulate
+ r-rspectra
+ r-scales
+ r-shape
+ r-shiny
+ r-sna
+ r-stringr
+ r-svglite))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/jinworks/CellChat")
+ (synopsis
+ "Inference of cell-cell communication from single-cell and transcriptomics")
+ (description
+ "This R tool infers, visualizes, and analyzes cell-cell communication networks.
+It supports scRNA-seq and spatially resolved transcriptomics data.")
+ (license license:gpl3))))
+
(define-public r-copykat
(let ((commit ;no tag
"256de33dfc1b80a1a0ac9e098c5557f95a4e0d53")