aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 09:23:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:39 +0100
commit4012ea04b41d7441d35c1e5da49f59f65d55bdf4 (patch)
tree61612d58bab74b63af22b48179a3ab184b8d2951
parent0ba940118f4311151581afe7255c4e61ea5fb983 (diff)
downloadguix-4012ea04b41d7441d35c1e5da49f59f65d55bdf4.tar
guix-4012ea04b41d7441d35c1e5da49f59f65d55bdf4.tar.gz
gnu: Add ghc-doctemplates.
* gnu/packages/haskell.scm (ghc-doctemplates): New variable.
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 5459762d56..3e57d18c4a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5673,6 +5673,37 @@ needs. It provides a very simple API to create sockets to a destination with
the choice of SSL/TLS, and SOCKS.")
(license license:bsd-3)))
+(define-public ghc-doctemplates
+ (package
+ (name "ghc-doctemplates")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "doctemplates/doctemplates-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1bfs2kl5j5al2w2y4qpbn68p0xsnb65r7h51l356kpkzc326646p"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-blaze-markup" ,ghc-blaze-markup)
+ ("ghc-blaze-html" ,ghc-blaze-html)
+ ("ghc-text" ,ghc-text)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-parsec" ,ghc-parsec)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-scientific" ,ghc-scientific)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)))
+ (home-page "https://github.com/jgm/doctemplates#readme")
+ (synopsis "Pandoc-style document templates")
+ (description
+ "This package provides a simple text templating system used by pandoc.")
+ (license license:bsd-3)))
+
(define-public ghc-pandoc
(package
(name "ghc-pandoc")