aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 09:23:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:39 +0100
commit0ba940118f4311151581afe7255c4e61ea5fb983 (patch)
treea959e8739a8f42a1b75eb448615801768dcd943e
parentd3c398cf4e0438efce034588fa31ced59e9b1539 (diff)
downloadguix-0ba940118f4311151581afe7255c4e61ea5fb983.tar
guix-0ba940118f4311151581afe7255c4e61ea5fb983.tar.gz
gnu: Add ghc-cmark-gfm.
* gnu/packages/haskell.scm (ghc-cmark-gfm): New variable.
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 19be937da9..5459762d56 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4977,6 +4977,34 @@ CommonMark, a fully specified variant of Markdown. It includes bundled libcmark
sources, and does not require prior installation of the C library.")
(license license:bsd-3)))
+(define-public ghc-cmark-gfm
+ (package
+ (name "ghc-cmark-gfm")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "cmark-gfm/cmark-gfm-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1fkisbrydmdx5h8yad09fzk8h1b1j53r02g7vb81izgdwj9b673k"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-text" ,ghc-text)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)))
+ (home-page "https://github.com/kivikakk/cmark-gfm-hs")
+ (synopsis
+ "Fast, accurate GitHub Flavored Markdown parser and renderer")
+ (description
+ "This package provides Haskell bindings for libcmark-gfm, the reference
+parser for GitHub Flavored Markdown, a fully specified variant of Markdown.
+It includes sources for libcmark-gfm and does not require prior installation
+of the C library.")
+ (license license:bsd-3)))
+
(define-public ghc-executable-path
(package
(name "ghc-executable-path")