aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-19 13:30:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-04-22 11:29:29 +0200
commit3c00ef084b5240c4493c5aba9d93da2095871f22 (patch)
tree96c1d5f1306a9090284dbd790ef1bdcc01bc430b
parent15f4363df07dd3d690bf808b8f7a9c6fef75fde5 (diff)
downloadguix-3c00ef084b5240c4493c5aba9d93da2095871f22.tar
guix-3c00ef084b5240c4493c5aba9d93da2095871f22.tar.gz
gnu: Add python-xarray-dataclasses.
* gnu/packages/python-science.scm (python-xarray-dataclasses): New variable. Change-Id: I55f258e36ea70a2efb142bd652a81d70771a457c
-rw-r--r--gnu/packages/python-science.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 862e101f6a..f5ad86caaa 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1223,6 +1223,31 @@ large and growing library of domain-agnostic functions for advanced analytics
and visualization with these data structures.")
(license license:asl2.0)))
+(define-public python-xarray-dataclasses
+ (package
+ (name "python-xarray-dataclasses")
+ (version "1.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astropenguin/xarray-dataclasses/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "043lc1hadr5y0y16g682viiafy0hfsa7q18lqmndpyvnmcgm893z"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-numpy python-typing-extensions
+ python-xarray))
+ (native-inputs (list python-poetry-core))
+ (home-page "https://github.com/astropenguin/xarray-dataclasses/")
+ (synopsis "xarray data creation made easy by dataclass")
+ (description "@code{xarray-dataclasses} is a Python package that makes it
+easy to create @code{xarray}'s @code{DataArray} and @code{Datase} objects that
+are \"typed\" (i.e. fixed dimensions, data type, coordinates, attributes, and
+name) using the Python's @code{dataclass}.")
+ (license license:expat)))
+
(define-public python-xarray-einstats
(package
(name "python-xarray-einstats")