aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-19 13:22:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-04-22 11:29:29 +0200
commit15f4363df07dd3d690bf808b8f7a9c6fef75fde5 (patch)
treeb1726c24a3b7aac76bb8991643be5dfedbe7bb17
parent5ac831d81b884401b9d255804de422b9f81cfacd (diff)
downloadguix-15f4363df07dd3d690bf808b8f7a9c6fef75fde5.tar
guix-15f4363df07dd3d690bf808b8f7a9c6fef75fde5.tar.gz
gnu: Add python-slicerator.
* gnu/packages/python-xyz.scm (python-slicerator): New variable. Change-Id: I9f24707f16cb34d25f6423b03fd07ea122d55064
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 57d34dae34..aa4689bf3f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1836,6 +1836,24 @@ class.")
library.")
(license license:expat)))
+(define-public python-slicerator
+ (package
+ (name "python-slicerator")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "slicerator" version))
+ (sha256
+ (base32 "0ik0bmh18zgffd9kx53254jp3yyih6zcmd8kfb080xnqbizhl0a4"))))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/soft-matter/slicerator")
+ (synopsis "Lazy-loading, fancy-sliceable iterable")
+ (description
+ "This package provides a lazy-loading, fancy-sliceable iterable. Think
+of it like a generator that is \"reusable\" and has a length.")
+ (license license:bsd-3)))
+
(define-public python-slixmpp
(package
(name "python-slixmpp")