aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-12-13 22:56:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-04-22 11:29:30 +0200
commit2b5cb248d3f6d297e6f83565fd5941aff8a39a21 (patch)
tree95bbfe6647e1a452b979a19e3ce5e027b89bd843
parent925e6d4072fa29b43d0869eae016d19a7833e182 (diff)
downloadguix-2b5cb248d3f6d297e6f83565fd5941aff8a39a21.tar
guix-2b5cb248d3f6d297e6f83565fd5941aff8a39a21.tar.gz
gnu: Add python-pytest-next.
* gnu/packages/check.scm (python-pytest-next): New variable.
-rw-r--r--gnu/packages/check.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 1e7ff1a317..fafa5d3f33 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1278,6 +1278,20 @@ and functions, detailed info on failing assert statements, modular fixtures,
and many external plugins.")
(license license:expat)))
+(define-public python-pytest-next
+ (package/inherit python-pytest
+ (name "python-pytest")
+ (version "7.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest" version))
+ (sha256
+ (base32 "02q32y67nflrmk9snmibq5kmqcbgfm29k9wm0yw0ia2vqly0m6gf"))))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs python-pytest)
+ (append python-exceptiongroup)))))
+
(define-deprecated python-pytest-6 python-pytest)
(export python-pytest-6)