aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-12-13 22:56:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-04-22 11:29:30 +0200
commit925e6d4072fa29b43d0869eae016d19a7833e182 (patch)
treea502eafecde36a96ae69e832ec571723e93e098a
parent43965c93aee12b1070bfbcb053af03d990f07bcf (diff)
downloadguix-925e6d4072fa29b43d0869eae016d19a7833e182.tar
guix-925e6d4072fa29b43d0869eae016d19a7833e182.tar.gz
gnu: python-contourpy: Update to 1.1.1.
* gnu/packages/python-xyz.scm (python-contourpy): Update to 1.1.1. Change-Id: I31ac27bb7f41f04c82baba2650012d4730a4b684
-rw-r--r--gnu/packages/python-xyz.scm37
1 files changed, 15 insertions, 22 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a1f5e6fb0a..c0eebde7ae 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1126,35 +1126,28 @@ into dataclasses.")
(define-public python-contourpy
(package
(name "python-contourpy")
- (version "1.1.0")
+ (version "1.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "contourpy" version))
(sha256
- (base32 "088bhyh6m6q0h637wiq2paqhwn76hqvvbhqwacfx4a1qhv1lcc75"))))
+ (base32 "1az80zv067rcybm5x93j7rfiakbwiv1h8l58gnki4wjbwb13gfln"))))
(build-system pyproject-build-system)
(arguments
- (list
- #:test-flags
- ;; All these tests require matplotlib, but matplotlib requires contourpy
- ;; now.
- '(list "-k" "not test_mypy"
- "--ignore=tests/test_config.py"
- "--ignore=tests/test_filled.py"
- "--ignore=tests/test_lines.py"
- "--ignore=tests/test_renderer.py")))
- (propagated-inputs (list python-mypy
- python-numpy
- python-pillow
- python-pytest
- python-pytest-cov
- python-pytest-xdist
- python-selenium
- python-sphinx
- python-sphinx-copybutton
- python-wurlitzer))
- (native-inputs (list meson-python pybind11-2.10 pkg-config))
+ ;; Image tests require matplotlib and create a circular dependency.
+ (list #:test-flags
+ #~(list "-m" "not image")))
+ (propagated-inputs
+ (list python-numpy))
+ (native-inputs
+ (list cmake
+ meson-python/newer
+ pkg-config
+ pybind11
+ python-pytest
+ python-pytest-cov
+ python-wurlitzer))
(home-page "https://contourpy.readthedocs.io/")
(synopsis
"Python library for calculating contours of 2D quadrilateral grids")