aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-12-09 10:42:54 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-09 10:42:54 +0000
commit35110450a38daac5a3d13d2d799d78732cd6c0f1 (patch)
treea7bbe9e6a343939d048ccab200a298d99d38beda
parent8f182d77f4e5c708a728148d6926d2ec1e66067d (diff)
downloadguix-fix-python-ipython.tar
guix-fix-python-ipython.tar.gz
-rw-r--r--gnu/packages/databases.scm6
-rw-r--r--gnu/packages/patches/python-pycodestyle-keep-compatability-with-stdlib-tokenize.py-changes.patch17
-rw-r--r--gnu/packages/python.scm31
3 files changed, 40 insertions, 14 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 0fa6d451ed..edd776ed2c 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -621,7 +621,7 @@ Language.")
(define-public mariadb
(package
(name "mariadb")
- (version "10.1.37")
+ (version "10.3.11")
(source (origin
(method url-fetch)
(uri (string-append "https://downloads.mariadb.org/f/"
@@ -629,8 +629,8 @@ Language.")
name "-" version ".tar.gz"))
(sha256
(base32
- "0ijdmdn9mcciwv361zfmja6b1h6qpbdqgrnnq6kkdapplyq1dmcc"))
- (patches (search-patches "mariadb-client-test-32bit.patch"))
+ "1cpi52ippd4x4fcq49lnya1fh0mcgrrr0v5yldxkkmf9jjvma5i1"))
+ ;(patches (search-patches "mariadb-client-test-32bit.patch"))
(modules '((guix build utils)))
(snippet
'(begin
diff --git a/gnu/packages/patches/python-pycodestyle-keep-compatability-with-stdlib-tokenize.py-changes.patch b/gnu/packages/patches/python-pycodestyle-keep-compatability-with-stdlib-tokenize.py-changes.patch
new file mode 100644
index 0000000000..66185d65e9
--- /dev/null
+++ b/gnu/packages/patches/python-pycodestyle-keep-compatability-with-stdlib-tokenize.py-changes.patch
@@ -0,0 +1,17 @@
+diff --git a/pycodestyle.py b/pycodestyle.py
+index 0d725d27..fbc3dca3 100755
+--- a/pycodestyle.py
++++ b/pycodestyle.py
+@@ -258,10 +258,10 @@ def trailing_blank_lines(physical_line, lines, line_number, total_lines):
+ """
+ if line_number == total_lines:
+ stripped_last_line = physical_line.rstrip()
+- if not stripped_last_line:
++ if physical_line and not stripped_last_line:
+ return 0, "W391 blank line at end of file"
+ if stripped_last_line == physical_line:
+- return len(physical_line), "W292 no newline at end of file"
++ return len(lines[-1]), "W292 no newline at end of file"
+
+
+ @register_check
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5cadc89d06..7ec34b4c62 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2501,14 +2501,14 @@ integrate Sphinx documents in web templates and to handle searches.")
(define-public python-sphinx
(package
(name "python-sphinx")
- (version "1.7.7")
+ (version "1.8.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Sphinx" version))
(sha256
(base32
- "0pkkbfj7cl157q550gcs45am5y78ps0h7q6455d64s1zmw01jlvi"))))
+ "1sia2h5rfzy76rbsd69ghr8bbidhsjzzinf3f523dcmivp5k41qj"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -3909,7 +3909,10 @@ as the original project seems to have been abandoned circa 2007.")
(uri (pypi-uri "pycodestyle" version))
(sha256
(base32
- "0fhy4vnlgpjq4qd1wdnl6pvdw7rah0ypmn8c9mkhz8clsndskz6b"))))
+ "0fhy4vnlgpjq4qd1wdnl6pvdw7rah0ypmn8c9mkhz8clsndskz6b"))
+ (patches
+ (search-patches
+ "python-pycodestyle-keep-compatability-with-stdlib-tokenize.py-changes.patch"))))
(build-system python-build-system)
(home-page "https://pycodestyle.readthedocs.io/")
(synopsis "Python style guide checker")
@@ -4902,6 +4905,11 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-intersphinx
+ (lambda _
+ (substitute* "docs/source/conf.py"
+ (("'sphinx\\.ext\\.intersphinx',") ""))
+ #t))
(add-after
'install 'install-doc
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -4917,17 +4925,18 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(add-installed-pythonpath inputs outputs)
(with-directory-excursion "docs"
;; FIXME: pdf fails to build
- ;;(system* "make" "pdf" "PAPER=a4")
- (system* "make" python-arg "html")
- (system* "make" python-arg "info"))
+ ;;(invoke "make" "pdf" "PAPER=a4")
+ (invoke "make" python-arg "html")
+ ;;(invoke "make" python-arg "info")
+ )
(copy-recursively "docs/man" man1)
(copy-recursively "examples" examples)
(copy-recursively "docs/build/html" html)
;; (copy-file "docs/build/latex/ipython.pdf"
;; (string-append doc "/ipython.pdf"))
- (mkdir-p info)
- (copy-file "docs/build/texinfo/ipython.info"
- (string-append info "/ipython.info"))
+ ;; (mkdir-p info)
+ ;; (copy-file "docs/build/texinfo/ipython.info"
+ ;; (string-append info "/ipython.info"))
(copy-file "COPYING.rst" (string-append doc "/COPYING.rst")))))
;; Tests can only be run after the library has been installed and not
;; within the source directory.
@@ -4940,8 +4949,8 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
;; Make installed package available for running the tests
(add-installed-pythonpath inputs outputs)
(setenv "HOME" "/tmp/") ;; required by a test
- (zero? (system* (string-append (assoc-ref outputs "out")
- "/bin/iptest"))))
+ (invoke (string-append (assoc-ref outputs "out")
+ "/bin/iptest")))
#t)))
(add-before
'install 'fix-tests