aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm31
1 files changed, 20 insertions, 11 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5cadc89d06..7ec34b4c62 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2501,14 +2501,14 @@ integrate Sphinx documents in web templates and to handle searches.")
(define-public python-sphinx
(package
(name "python-sphinx")
- (version "1.7.7")
+ (version "1.8.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Sphinx" version))
(sha256
(base32
- "0pkkbfj7cl157q550gcs45am5y78ps0h7q6455d64s1zmw01jlvi"))))
+ "1sia2h5rfzy76rbsd69ghr8bbidhsjzzinf3f523dcmivp5k41qj"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -3909,7 +3909,10 @@ as the original project seems to have been abandoned circa 2007.")
(uri (pypi-uri "pycodestyle" version))
(sha256
(base32
- "0fhy4vnlgpjq4qd1wdnl6pvdw7rah0ypmn8c9mkhz8clsndskz6b"))))
+ "0fhy4vnlgpjq4qd1wdnl6pvdw7rah0ypmn8c9mkhz8clsndskz6b"))
+ (patches
+ (search-patches
+ "python-pycodestyle-keep-compatability-with-stdlib-tokenize.py-changes.patch"))))
(build-system python-build-system)
(home-page "https://pycodestyle.readthedocs.io/")
(synopsis "Python style guide checker")
@@ -4902,6 +4905,11 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-intersphinx
+ (lambda _
+ (substitute* "docs/source/conf.py"
+ (("'sphinx\\.ext\\.intersphinx',") ""))
+ #t))
(add-after
'install 'install-doc
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -4917,17 +4925,18 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(add-installed-pythonpath inputs outputs)
(with-directory-excursion "docs"
;; FIXME: pdf fails to build
- ;;(system* "make" "pdf" "PAPER=a4")
- (system* "make" python-arg "html")
- (system* "make" python-arg "info"))
+ ;;(invoke "make" "pdf" "PAPER=a4")
+ (invoke "make" python-arg "html")
+ ;;(invoke "make" python-arg "info")
+ )
(copy-recursively "docs/man" man1)
(copy-recursively "examples" examples)
(copy-recursively "docs/build/html" html)
;; (copy-file "docs/build/latex/ipython.pdf"
;; (string-append doc "/ipython.pdf"))
- (mkdir-p info)
- (copy-file "docs/build/texinfo/ipython.info"
- (string-append info "/ipython.info"))
+ ;; (mkdir-p info)
+ ;; (copy-file "docs/build/texinfo/ipython.info"
+ ;; (string-append info "/ipython.info"))
(copy-file "COPYING.rst" (string-append doc "/COPYING.rst")))))
;; Tests can only be run after the library has been installed and not
;; within the source directory.
@@ -4940,8 +4949,8 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
;; Make installed package available for running the tests
(add-installed-pythonpath inputs outputs)
(setenv "HOME" "/tmp/") ;; required by a test
- (zero? (system* (string-append (assoc-ref outputs "out")
- "/bin/iptest"))))
+ (invoke (string-append (assoc-ref outputs "out")
+ "/bin/iptest")))
#t)))
(add-before
'install 'fix-tests