aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2010-01-19 14:53:38 +0100
committerSebastian Hahn <sebastian@torproject.org>2010-01-27 12:13:10 +0100
commita330cdc6fb9b02c3ee3d2282713a2052ff909b62 (patch)
treef84f3724cf3ebf8f06bd1a9aeefff7d09ba1c841 /doc/Makefile.am
parentce860d8efd73526469ba1de3e8e3665312594940 (diff)
downloadtor-a330cdc6fb9b02c3ee3d2282713a2052ff909b62.tar
tor-a330cdc6fb9b02c3ee3d2282713a2052ff909b62.tar.gz
Convert the Tor manpage to asciidoc.
This should be a very faithful conversion, preserving as much of the layout of the old manpage as possible. This wasn't possible for the nt-service and the DataDirectory/state parts. See a later commit for some small cleanups. Tiago Faria helped with the asciidoc conversion, big thanks!
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 2a6bba965..25d0a64b2 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,4 +1,4 @@
-asciidoc_files = tor-gencert tor-resolve torify
+asciidoc_files = tor tor-gencert tor-resolve torify
html_in = $(asciidoc_files:=.html.in)
@@ -9,7 +9,7 @@ EXTRA_DIST = HACKING \
tor-osx-dmg-creation.txt tor-rpm-creation.txt \
tor-win32-mingw-creation.txt
-nodist_man_MANS = tor.1 $(asciidoc_files:=.1)
+nodist_man_MANS = $(asciidoc_files:=.1)
doc_DATA = $(asciidoc_files:=.html)
@@ -24,6 +24,7 @@ DIST_SUBDIRS = design-paper spec
$(html_in) :
$(top_srcdir)/doc/asciidoc-helper.sh html @ASCIIDOC@ @SED@ $@
+tor.html.in : tor.1.txt
torify.html.in : torify.1.txt
tor-gencert.html.in : tor-gencert.1.txt
tor-resolve.html.in : tor-resolve.1.txt
@@ -33,6 +34,7 @@ tor-resolve.html.in : tor-resolve.1.txt
$(man_in) :
$(top_srcdir)/doc/asciidoc-helper.sh man @A2X@ @SED@ $@
+tor.1.in : tor.1.txt
torify.1.in : torify.1.txt
tor-gencert.1.in : tor-gencert.1.txt
tor-resolve.1.in : tor-resolve.1.txt
@@ -42,9 +44,11 @@ tor-resolve.1.in : tor-resolve.1.txt
$(asciidoc_product) :
../config.status --file=$@;
+tor.1 : tor.1.in
torify.1 : torify.1.in
tor-gencert.1 : tor-gencert.1.in
tor-resolve.1 : tor-resolve.1.in
+tor.html : tor.html.in
torify.html : torify.html.in
tor-gencert.html : tor-gencert.html.in
tor-resolve.html : tor-resolve.html.in