aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrea Shepard <andrea@torproject.org>2014-05-16 08:51:51 -0700
committerAndrea Shepard <andrea@torproject.org>2014-05-16 08:51:51 -0700
commitf7a55bc4b4a5f0e9323275a99f8c6ceec9f5f1d5 (patch)
treec838caa4ea85c52ece770e60d6bdc0a47152f141 /configure.ac
parent39d4e67be8283b2a7141a7aa8342d30e27f47e6f (diff)
downloadtor-f7a55bc4b4a5f0e9323275a99f8c6ceec9f5f1d5.tar
tor-f7a55bc4b4a5f0e9323275a99f8c6ceec9f5f1d5.tar.gz
Turn --enable-mempools off by default
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 255dcea08..207763b7b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,7 +26,7 @@ CPPFLAGS="$CPPFLAGS -I\${top_srcdir}/src/common"
AC_ARG_ENABLE(buf-freelists,
AS_HELP_STRING(--enable-buf-freelists, enable freelists for buffer RAM))
AC_ARG_ENABLE(mempools,
- AS_HELP_STRING(--disable-mempools, disable mempools for relay cells))
+ AS_HELP_STRING(--enable-mempools, enable mempools for relay cells))
AC_ARG_ENABLE(openbsd-malloc,
AS_HELP_STRING(--enable-openbsd-malloc, Use malloc code from openbsd. Linux only))
AC_ARG_ENABLE(instrument-downloads,
@@ -61,8 +61,8 @@ if test x$enable_buf_freelists = xyes; then
[Defined if we try to use freelists for buffer RAM chunks])
fi
-AM_CONDITIONAL(USE_MEMPOOLS, test x$enable_mempools != xno)
-if test x$enable_mempools != xno; then
+AM_CONDITIONAL(USE_MEMPOOLS, test x$enable_mempools = xyes)
+if test x$enable_mempools = xyes; then
AC_DEFINE(ENABLE_MEMPOOLS, 1,
[Defined if we try to use mempools for cells being relayed])
fi