aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrea Shepard <andrea@torproject.org>2014-05-12 18:23:34 -0700
committerAndrea Shepard <andrea@torproject.org>2014-05-12 18:23:34 -0700
commit39d4e67be8283b2a7141a7aa8342d30e27f47e6f (patch)
treedbc602ce1470c3e8c7b2d13ec89336464b563956 /configure.ac
parent17435384c050b29cd3c70819ac7176c407f4d1bb (diff)
downloadtor-39d4e67be8283b2a7141a7aa8342d30e27f47e6f.tar
tor-39d4e67be8283b2a7141a7aa8342d30e27f47e6f.tar.gz
Add --disable-mempools configure option
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 936d61bb2..255dcea08 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,8 @@ CPPFLAGS="$CPPFLAGS -I\${top_srcdir}/src/common"
#XXXX020 We should make these enabled or not, before 0.2.0.x-final
AC_ARG_ENABLE(buf-freelists,
AS_HELP_STRING(--enable-buf-freelists, enable freelists for buffer RAM))
+AC_ARG_ENABLE(mempools,
+ AS_HELP_STRING(--disable-mempools, disable mempools for relay cells))
AC_ARG_ENABLE(openbsd-malloc,
AS_HELP_STRING(--enable-openbsd-malloc, Use malloc code from openbsd. Linux only))
AC_ARG_ENABLE(instrument-downloads,
@@ -58,6 +60,13 @@ if test x$enable_buf_freelists = xyes; then
AC_DEFINE(ENABLE_BUF_FREELISTS, 1,
[Defined if we try to use freelists for buffer RAM chunks])
fi
+
+AM_CONDITIONAL(USE_MEMPOOLS, test x$enable_mempools != xno)
+if test x$enable_mempools != xno; then
+ AC_DEFINE(ENABLE_MEMPOOLS, 1,
+ [Defined if we try to use mempools for cells being relayed])
+fi
+
AM_CONDITIONAL(USE_OPENBSD_MALLOC, test x$enable_openbsd_malloc = xyes)
if test x$enable_instrument_downloads = xyes; then
AC_DEFINE(INSTRUMENT_DOWNLOADS, 1,