aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2014-04-30 17:21:15 -0400
committerNick Mathewson <nickm@torproject.org>2014-04-30 17:21:15 -0400
commitf43fee8f8f194af475932f5312b2e538770d3c94 (patch)
tree7a01d1efd5e9cadb4050ef6400dd512f872892b4 /configure.ac
parent14efaa028382a75f97371cc15c3d0e49b7d7728d (diff)
parent904dd436b58a63d430d09038a2d0edcc1133798f (diff)
downloadtor-f43fee8f8f194af475932f5312b2e538770d3c94.tar
tor-f43fee8f8f194af475932f5312b2e538770d3c94.tar.gz
Merge remote-tracking branch 'public/bug11628'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c0c818757..3ef5cdd7d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -161,6 +161,9 @@ AC_ARG_ENABLE(bufferevents,
AC_ARG_ENABLE(tool-name-check,
AS_HELP_STRING(--disable-tool-name-check, check for sanely named toolchain when cross-compiling))
+AC_ARG_ENABLE(seccomp,
+ AS_HELP_STRING(--disable-seccomp, do not attempt to use libseccomp))
+
dnl check for the correct "ar" when cross-compiling
AN_MAKEVAR([AR], [AC_PROG_AR])
AN_PROGRAM([ar], [AC_PROG_AR])
@@ -726,8 +729,10 @@ fi
dnl ============================================================
dnl Check for libseccomp
-AC_CHECK_HEADERS([seccomp.h])
-AC_SEARCH_LIBS(seccomp_init, [seccomp])
+if test "x$enable_seccomp" != "xno"; then
+ AC_CHECK_HEADERS([seccomp.h])
+ AC_SEARCH_LIBS(seccomp_init, [seccomp])
+fi
dnl ============================================================
dnl We need an implementation of curve25519.