aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2014-04-28 11:11:11 -0400
committerNick Mathewson <nickm@torproject.org>2014-04-28 11:11:50 -0400
commit904dd436b58a63d430d09038a2d0edcc1133798f (patch)
tree79bd91b988ee5a02282f6ac2f1964424f0f85122 /configure.ac
parentf4be34f70d6f277a0f3f73e62ed358564588e92b (diff)
downloadtor-904dd436b58a63d430d09038a2d0edcc1133798f.tar
tor-904dd436b58a63d430d09038a2d0edcc1133798f.tar.gz
New --disable-seccomp option to turn off support for seccomp.
Fixes 11628.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index edfe2f8e9..8b5e853ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -161,6 +161,9 @@ AC_ARG_ENABLE(bufferevents,
AC_ARG_ENABLE(tool-name-check,
AS_HELP_STRING(--disable-tool-name-check, check for sanely named toolchain when cross-compiling))
+AC_ARG_ENABLE(seccomp,
+ AS_HELP_STRING(--disable-seccomp, do not attempt to use libseccomp))
+
dnl check for the correct "ar" when cross-compiling
AN_MAKEVAR([AR], [AC_PROG_AR])
AN_PROGRAM([ar], [AC_PROG_AR])
@@ -726,8 +729,10 @@ fi
dnl ============================================================
dnl Check for libseccomp
-AC_CHECK_HEADERS([seccomp.h])
-AC_SEARCH_LIBS(seccomp_init, [seccomp])
+if test "x$enable_seccomp" != "xno"; then
+ AC_CHECK_HEADERS([seccomp.h])
+ AC_SEARCH_LIBS(seccomp_init, [seccomp])
+fi
dnl ============================================================
dnl We need an implementation of curve25519.