aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-07-19 14:18:43 -0400
committerNick Mathewson <nickm@torproject.org>2013-11-18 10:43:14 -0500
commitb0023083c413c6447ef34cf3c6cfaf54a1cc8793 (patch)
tree8be94afa1b330d7149113947b9a5542adda2f5c6 /configure.ac
parent063bea58bcc1c27864a0351bba07254855903377 (diff)
downloadtor-b0023083c413c6447ef34cf3c6cfaf54a1cc8793.tar
tor-b0023083c413c6447ef34cf3c6cfaf54a1cc8793.tar.gz
On Linux (and some other systems) we need -rdynamic for backtraces
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5059079f7..8e247db32 100644
--- a/configure.ac
+++ b/configure.ac
@@ -593,6 +593,9 @@ if test x$enable_linker_hardening != xno; then
TOR_CHECK_LDFLAGS(-z relro -z now, "$all_ldflags_for_check", "$all_libs_for_check")
fi
+# For backtrace support
+TOR_CHECK_LDFLAGS(-rdynamic)
+
dnl ------------------------------------------------------
dnl Now see if we have a -fomit-frame-pointer compiler option.