aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-07-19 14:09:58 -0400
committerNick Mathewson <nickm@torproject.org>2013-11-18 10:43:14 -0500
commit063bea58bcc1c27864a0351bba07254855903377 (patch)
tree8a0f0ea303fbbc4b86d31c54dd9da761f658f4e2 /configure.ac
parentf6d8bc9389db72dc654560d0f86fd3edd3b14934 (diff)
downloadtor-063bea58bcc1c27864a0351bba07254855903377.tar
tor-063bea58bcc1c27864a0351bba07254855903377.tar.gz
Basic backtrace ability
On platforms with the backtrace/backtrace_symbols_fd interface, Tor can now dump stack traces on assertion failure. By default, I log them to DataDir/stack_dump and to stderr.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4aeec929e..5059079f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -302,6 +302,8 @@ dnl exports strlcpy without defining it in a header.
AC_CHECK_FUNCS(
_NSGetEnviron \
accept4 \
+ backtrace \
+ backtrace_symbols_fd \
clock_gettime \
flock \
ftime \
@@ -319,6 +321,7 @@ AC_CHECK_FUNCS(
memmem \
prctl \
rint \
+ sigaction \
socketpair \
strlcat \
strlcpy \
@@ -802,6 +805,7 @@ dnl These headers are not essential
AC_CHECK_HEADERS(
arpa/inet.h \
crt_externs.h \
+ execinfo.h \
grp.h \
ifaddrs.h \
inttypes.h \