aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrea Shepard <andrea@torproject.org>2014-05-12 17:28:26 -0700
committerAndrea Shepard <andrea@torproject.org>2014-05-12 17:28:26 -0700
commit17435384c050b29cd3c70819ac7176c407f4d1bb (patch)
tree0a743b2635ea6a4c630cf04bf753814973a189c7 /configure.ac
parent91ff10f6be984c6ca00a7240d32e79ab7db09c7c (diff)
downloadtor-17435384c050b29cd3c70819ac7176c407f4d1bb.tar
tor-17435384c050b29cd3c70819ac7176c407f4d1bb.tar.gz
Turn --enable-buf-freelists off by default
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f921dd503..936d61bb2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,7 @@ CPPFLAGS="$CPPFLAGS -I\${top_srcdir}/src/common"
#XXXX020 We should make these enabled or not, before 0.2.0.x-final
AC_ARG_ENABLE(buf-freelists,
- AS_HELP_STRING(--disable-buf-freelists, disable freelists for buffer RAM))
+ AS_HELP_STRING(--enable-buf-freelists, enable freelists for buffer RAM))
AC_ARG_ENABLE(openbsd-malloc,
AS_HELP_STRING(--enable-openbsd-malloc, Use malloc code from openbsd. Linux only))
AC_ARG_ENABLE(instrument-downloads,
@@ -54,7 +54,7 @@ if test "$enable_static_tor" = "yes"; then
CFLAGS="$CFLAGS -static"
fi
-if test x$enable_buf_freelists != xno; then
+if test x$enable_buf_freelists = xyes; then
AC_DEFINE(ENABLE_BUF_FREELISTS, 1,
[Defined if we try to use freelists for buffer RAM chunks])
fi