aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLinus Nordberg <linus@torproject.org>2013-06-05 15:48:57 +0200
committerLinus Nordberg <linus@torproject.org>2013-06-13 16:33:56 +0200
commitc82d7950ad9a1614a8f3929f53eaed572c9d9e2e (patch)
tree63a28862b5a02db4a898593d0c2efb18f8b32414 /Makefile.am
parentc132427db4f207a32e4abaae0e070840e5e2b808 (diff)
downloadtor-c82d7950ad9a1614a8f3929f53eaed572c9d9e2e.tar
tor-c82d7950ad9a1614a8f3929f53eaed572c9d9e2e.tar.gz
Add make target test-network running traffic tests in a Chutney network.
This implements ticket #8530.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4639c22c4..e9976fa65 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,6 +60,10 @@ doxygen:
test: all
./src/test/test
+# Requires a copy of Chutney in ./chutney
+test-network: all
+ ./src/test/test-network.sh
+
# Avoid strlcpy.c, strlcat.c, aes.c, OpenBSD_malloc_Linux.c, sha256.c,
# eventdns.[hc], tinytest*.[ch]
check-spaces: