aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c9d82a1..8adac87 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,12 @@ export PYBUILD_NAME=requests
%:
dh $@ --with python2,python3 --buildsystem=pybuild
+override_dh_auto_test:
+ PYBUILD_SYSTEM=custom \
+ PYBUILD_TEST_ARGS="{interpreter} test_requests.py" \
+ http_proxy= https_proxy= \
+ dh_auto_test
+
override_dh_installchangelogs:
dh_installchangelogs HISTORY.rst