aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorBarry Warsaw <barry@debian.org>2014-06-04 14:34:39 +0000
committerBarry Warsaw <barry@debian.org>2014-06-04 14:34:39 +0000
commit7564f06a88cafa130ae90969441b9e768ed20373 (patch)
tree60d638ea6804aced4c869e5a276eea4e07d2da19 /debian/rules
parentfc561b562b377f42f72f711696b98661c05cd096 (diff)
downloadpython-requests-7564f06a88cafa130ae90969441b9e768ed20373.tar
python-requests-7564f06a88cafa130ae90969441b9e768ed20373.tar.gz
* Team upload.
* New upstream release. * d/patches/*: Refreshed. * d/control: Added python{,3}-pytest to Build-Depends. * d/rules: Fixed running of test suite during package build.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c9d82a1..8adac87 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,12 @@ export PYBUILD_NAME=requests
%:
dh $@ --with python2,python3 --buildsystem=pybuild
+override_dh_auto_test:
+ PYBUILD_SYSTEM=custom \
+ PYBUILD_TEST_ARGS="{interpreter} test_requests.py" \
+ http_proxy= https_proxy= \
+ dh_auto_test
+
override_dh_installchangelogs:
dh_installchangelogs HISTORY.rst