aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSVN-Git Migration <python-modules-team@lists.alioth.debian.org>2015-10-08 13:41:23 -0700
committerSVN-Git Migration <python-modules-team@lists.alioth.debian.org>2015-10-08 13:41:23 -0700
commitd4aa2de2bb89ca384ad81db731bb99735e1db788 (patch)
tree68092157eef070d7d87c330f206eb96209e09074 /setup.py
parent3a4ef8165fb2951781a7bcc4189e90faf26caf2d (diff)
downloadpython-requests-d4aa2de2bb89ca384ad81db731bb99735e1db788.tar
python-requests-d4aa2de2bb89ca384ad81db731bb99735e1db788.tar.gz
Imported Upstream version 0.12.1
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py42
1 files changed, 29 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index 3133a97..1ab216b 100755
--- a/setup.py
+++ b/setup.py
@@ -1,27 +1,26 @@
#!/usr/bin/env python
-# -*- coding: utf-8 -*-
+
+"""
+distutils/setuptools install script. See inline comments for packaging documentation.
+"""
import os
import sys
+
import requests
-from requests.compat import is_py3, is_py2
+from requests.compat import is_py3
try:
from setuptools import setup
+ # hush pyflakes
+ setup
except ImportError:
from distutils.core import setup
-
-
if sys.argv[-1] == 'publish':
os.system('python setup.py sdist upload')
sys.exit()
-if sys.argv[-1] == 'test':
- os.system('python tests/test_requests.py')
- sys.exit()
-
-required = ['certifi>=0.0.7',]
packages = [
'requests',
'requests.packages',
@@ -31,12 +30,28 @@ packages = [
'requests.packages.urllib3.packages.mimetools_choose_boundary',
]
+# certifi is a Python package containing a CA certificate bundle for SSL verification.
+# On certain supported platforms (e.g., Red Hat / Debian / FreeBSD), Requests can
+# use the system CA bundle instead; see `requests.utils` for details.
+# If your platform is supported, set `requires` to [] instead:
+requires = ['certifi>=0.0.7']
+
+# chardet is used to optimally guess the encodings of pages that don't declare one.
+# At this time, chardet is not a required dependency. However, it's sufficiently
+# important that pip/setuptools should install it when it's unavailable.
if is_py3:
- required.append('chardet2')
+ chardet_package = 'chardet2'
else:
- required.append('chardet>=1.0.0')
- packages.append('requests.packages.oreos')
+ chardet_package = 'chardet>=1.0.0'
+ requires.append('oauthlib>=0.1.0,<0.2.0')
+
+requires.append(chardet_package)
+# The async API in requests.async requires the gevent package.
+# This is also not a required dependency.
+extras_require = {
+ 'async': ['gevent'],
+}
setup(
name='requests',
@@ -50,7 +65,8 @@ setup(
packages=packages,
package_data={'': ['LICENSE', 'NOTICE']},
include_package_data=True,
- install_requires=required,
+ install_requires=requires,
+ extras_require=extras_require,
license=open("LICENSE").read(),
classifiers=(
'Development Status :: 5 - Production/Stable',