aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSVN-Git Migration <python-modules-team@lists.alioth.debian.org>2015-10-08 13:41:25 -0700
committerSVN-Git Migration <python-modules-team@lists.alioth.debian.org>2015-10-08 13:41:25 -0700
commit9f376f89bdf80a40914218d64cd9cd61b25f449d (patch)
tree6205015b49c53a3178573532cfcd10dcd7f2d121 /setup.py
parentd4aa2de2bb89ca384ad81db731bb99735e1db788 (diff)
downloadpython-requests-9f376f89bdf80a40914218d64cd9cd61b25f449d.tar
python-requests-9f376f89bdf80a40914218d64cd9cd61b25f449d.tar.gz
Imported Upstream version 1.1.0
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py47
1 files changed, 11 insertions, 36 deletions
diff --git a/setup.py b/setup.py
index 1ab216b..795774e 100755
--- a/setup.py
+++ b/setup.py
@@ -1,19 +1,12 @@
#!/usr/bin/env python
-"""
-distutils/setuptools install script. See inline comments for packaging documentation.
-"""
-
import os
import sys
import requests
-from requests.compat import is_py3
try:
from setuptools import setup
- # hush pyflakes
- setup
except ImportError:
from distutils.core import setup
@@ -24,34 +17,13 @@ if sys.argv[-1] == 'publish':
packages = [
'requests',
'requests.packages',
+ 'requests.packages.charade',
'requests.packages.urllib3',
'requests.packages.urllib3.packages',
- 'requests.packages.urllib3.packages.ssl_match_hostname',
- 'requests.packages.urllib3.packages.mimetools_choose_boundary',
+ 'requests.packages.urllib3.packages.ssl_match_hostname'
]
-# certifi is a Python package containing a CA certificate bundle for SSL verification.
-# On certain supported platforms (e.g., Red Hat / Debian / FreeBSD), Requests can
-# use the system CA bundle instead; see `requests.utils` for details.
-# If your platform is supported, set `requires` to [] instead:
-requires = ['certifi>=0.0.7']
-
-# chardet is used to optimally guess the encodings of pages that don't declare one.
-# At this time, chardet is not a required dependency. However, it's sufficiently
-# important that pip/setuptools should install it when it's unavailable.
-if is_py3:
- chardet_package = 'chardet2'
-else:
- chardet_package = 'chardet>=1.0.0'
- requires.append('oauthlib>=0.1.0,<0.2.0')
-
-requires.append(chardet_package)
-
-# The async API in requests.async requires the gevent package.
-# This is also not a required dependency.
-extras_require = {
- 'async': ['gevent'],
-}
+requires = []
setup(
name='requests',
@@ -63,21 +35,24 @@ setup(
author_email='me@kennethreitz.com',
url='http://python-requests.org',
packages=packages,
- package_data={'': ['LICENSE', 'NOTICE']},
+ package_data={'': ['LICENSE', 'NOTICE'], 'requests': ['*.pem']},
+ package_dir={'requests': 'requests'},
include_package_data=True,
install_requires=requires,
- extras_require=extras_require,
- license=open("LICENSE").read(),
+ license=open('LICENSE').read(),
+ zip_safe=False,
classifiers=(
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
'Natural Language :: English',
- 'License :: OSI Approved :: ISC License (ISCL)',
+ 'License :: OSI Approved :: Apache Software License',
'Programming Language :: Python',
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.0',
+ # 'Programming Language :: Python :: 3.0',
'Programming Language :: Python :: 3.1',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
),
)