aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDaniele Tricoli <eriol@mornie.org>2012-02-05 04:47:05 +0000
committerDaniele Tricoli <eriol@mornie.org>2012-02-05 04:47:05 +0000
commitfa4dfd1bcf247a82315380832c48ea95dd647739 (patch)
tree5a979babb378b3a7f55bc881a52b1e4e2ffc72dc /debian
parentfff91a31e7206679e77f83b2ee3bfc4305ff8557 (diff)
downloadpython-requests-fa4dfd1bcf247a82315380832c48ea95dd647739.tar
python-requests-fa4dfd1bcf247a82315380832c48ea95dd647739.tar.gz
Added override_dh_auto_clean to make the package build twice in a row
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rwxr-xr-xdebian/rules4
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index fd1d478..9e04c7c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,11 +3,11 @@ requests (0.10.1-1) UNRELEASED; urgency=low
* New upstream release
- Adds Python 3 support
* Builded python 3 package
- - B-D on python3-all
* debian/control
- Added python-chardet to Recommends
- Bumped X-Python-Version >= 2.6
- Added ca-certificates to Depends
+ - Added python3-all to Build-Depends
* debian/copyright
- Updated Format URI
- Updated copyright years
@@ -17,6 +17,8 @@ requests (0.10.1-1) UNRELEASED; urgency=low
* debian/patches/02_fix-python3-except-sintax-error.patches
- Fix SyntaxError on Python3 because "except Error, e" is not supported
anymore
+ * debian/rules
+ - Added override_dh_auto_clean to make the package build twice in a row
-- Daniele Tricoli <eriol@mornie.org> Sun, 05 Feb 2012 04:51:38 +0100
diff --git a/debian/rules b/debian/rules
index ebc4147..af9831c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,6 +12,10 @@ override_dh_auto_build:
$$python setup.py build; \
done
+override_dh_auto_clean:
+ rm -rf build
+ dh_auto_clean
+
override_dh_auto_install:
set -ex; \
for python in $(PYVERS); do \