aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDaniele Tricoli <eriol@mornie.org>2012-02-05 04:12:34 +0000
committerDaniele Tricoli <eriol@mornie.org>2012-02-05 04:12:34 +0000
commitfff91a31e7206679e77f83b2ee3bfc4305ff8557 (patch)
tree04e5a59adbc7828ef66bb05eadb6bd76b1399874 /debian
parent78b13cd0a8a4cd4aff0e975b770da6bb2a6c4497 (diff)
downloadpython-requests-fff91a31e7206679e77f83b2ee3bfc4305ff8557.tar
python-requests-fff91a31e7206679e77f83b2ee3bfc4305ff8557.tar.gz
Added python3 package
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/control36
-rwxr-xr-xdebian/rules26
3 files changed, 61 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 5d8d812..fd1d478 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,9 @@
requests (0.10.1-1) UNRELEASED; urgency=low
* New upstream release
+ - Adds Python 3 support
+ * Builded python 3 package
+ - B-D on python3-all
* debian/control
- Added python-chardet to Recommends
- Bumped X-Python-Version >= 2.6
diff --git a/debian/control b/debian/control
index ed6dcc8..94839e2 100644
--- a/debian/control
+++ b/debian/control
@@ -3,10 +3,13 @@ Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.
Uploaders: Daniele Tricoli <eriol@mornie.org>
Section: python
Priority: optional
-Build-Depends: debhelper (>= 7.0.50~),
- python-all (>= 2.6.6-3),
+Build-Depends:
+ debhelper (>= 7.0.50~),
+ python-all (>= 2.6.6-3),
+ python3-all
Standards-Version: 3.9.2
X-Python-Version: >= 2.6
+X-Python3-Version: >= 3.0
Homepage: http://python-requests.org
Vcs-Svn: svn://svn.debian.org/python-modules/packages/requests/trunk/
Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/requests/trunk/
@@ -40,3 +43,32 @@ Description: elegant and simple HTTP library for Python, built for human beings
- Auto Decompression of GZipped Content
- Unicode URL Support
- Simple Authentication: Simple URL + HTTP Auth Registry
+
+Package: python3-requests
+Architecture: all
+Depends:
+ ${misc:Depends},
+ ${python:Depends},
+ ca-certificates
+Description: elegant and simple HTTP library for Python3, built for human beings
+ Requests allow you to send GET, HEAD, PUT, POST, and DELETE
+ HTTP requests. You can add headers, form data, multipart files, and
+ parameters with simple Python dictionaries, and access the response
+ data in the same way. It's powered by urllib2, but it does all the
+ hard work and crazy hacks for you.
+ .
+ Features
+ .
+ - Extremely simple GET, HEAD, POST, PUT, DELETE Requests
+ - Simple HTTP Header Request Attachment
+ - Simple Data/Params Request Attachment
+ - Simple Multipart File Uploads
+ - CookieJar Support
+ - Redirection History
+ - Proxy Support
+ - Redirection Recursion Urllib Fix
+ - Auto Decompression of GZipped Content
+ - Unicode URL Support
+ - Simple Authentication: Simple URL + HTTP Auth Registry
+ .
+ This package contains the Python 3 version of the library.
diff --git a/debian/rules b/debian/rules
index 8fcc582..ebc4147 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,29 @@
#!/usr/bin/make -f
+PYVERS := $(shell pyversions -r)
+PY3VERS := $(shell py3versions -r)
+
%:
- dh $@ --with python2 --buildsystem=python_distutils
+ dh $@ --with python2,python3 --buildsystem=python_distutils
+
+override_dh_auto_build:
+ set -ex; \
+ for python in $(PYVERS) $(PY3VERS); do \
+ $$python setup.py build; \
+ done
+
+override_dh_auto_install:
+ set -ex; \
+ for python in $(PYVERS); do \
+ $$python setup.py install --skip-build --root debian/python-requests \
+ --install-layout deb; \
+ done
+
+ set -ex; \
+ for python in $(PY3VERS); do \
+ $$python setup.py install --skip-build --root debian/python3-requests \
+ --install-layout deb; \
+ done
override_dh_installchangelogs:
- dh_installchangelogs HISTORY.rst upstream
+ dh_installchangelogs HISTORY.rst