aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPer Andersson <avtobiff@gmail.com>2014-01-30 01:25:15 +0100
committerPer Andersson <avtobiff@gmail.com>2014-01-30 01:25:15 +0100
commitc084fbcb2e2f2f167c8d65ca1ecfee406f14c24b (patch)
tree6c5ca20a48eb50ea000748abb5374247d6de1888 /setup.py
parent973d326d7847161827a8f75b5f589008a83a342d (diff)
parent6cff86ce6de27fbd4f9fc07716fb1205b14ffae4 (diff)
downloadpython-bleach-c084fbcb2e2f2f167c8d65ca1ecfee406f14c24b.tar
python-bleach-c084fbcb2e2f2f167c8d65ca1ecfee406f14c24b.tar.gz
Merge tag 'upstream/1.4'
Upstream version 1.4 # gpg: Signature made Thu 30 Jan 2014 01:25:12 AM CET using RSA key ID 79F492F8 # gpg: Good signature from "Per Andersson <avtobiff@fripost.org>" # gpg: aka "Per Andersson <avtobiff@debian.org>" # gpg: aka "Per Andersson <avtobiff@gmail.com>" # gpg: aka "Per Andersson <avtobiff@foo.nu>"
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 15 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index e48c3f7..6d5cfb4 100644
--- a/setup.py
+++ b/setup.py
@@ -2,26 +2,35 @@ from setuptools import setup, find_packages
setup(
name='bleach',
- version='1.2.2',
+ version='1.4',
description='An easy whitelist-based HTML-sanitizing tool.',
long_description=open('README.rst').read(),
author='James Socol',
- author_email='james@mozilla.com',
+ author_email='me@jamessocol.com',
url='http://github.com/jsocol/bleach',
- license='BSD',
+ license='Apache Software License',
packages=find_packages(),
include_package_data=True,
package_data={'': ['README.rst']},
zip_safe=False,
- install_requires=['html5lib==0.95'],
+ install_requires=[
+ 'six',
+ 'html5lib>=0.999',
+ ],
classifiers=[
- 'Development Status :: 4 - Beta',
+ 'Development Status :: 5 - Production/Stable',
'Environment :: Web Environment',
'Environment :: Web Environment :: Mozilla',
'Intended Audience :: Developers',
- 'License :: OSI Approved :: BSD License',
+ 'License :: OSI Approved :: Apache Software License',
'Operating System :: OS Independent',
'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
'Topic :: Software Development :: Libraries :: Python Modules',
]
)