aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPer Andersson <avtobiff@gmail.com>2014-01-30 01:25:11 +0100
committerPer Andersson <avtobiff@gmail.com>2014-01-30 01:25:11 +0100
commit6cff86ce6de27fbd4f9fc07716fb1205b14ffae4 (patch)
tree15d1f032fcf000801b69307d2463c10004489ee4 /setup.py
parentfac84c6d90e0875e6c1b10c5ef02d577ee008af4 (diff)
downloadpython-bleach-6cff86ce6de27fbd4f9fc07716fb1205b14ffae4.tar
python-bleach-6cff86ce6de27fbd4f9fc07716fb1205b14ffae4.tar.gz
Imported Upstream version 1.4upstream/1.4
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 15 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index e48c3f7..6d5cfb4 100644
--- a/setup.py
+++ b/setup.py
@@ -2,26 +2,35 @@ from setuptools import setup, find_packages
setup(
name='bleach',
- version='1.2.2',
+ version='1.4',
description='An easy whitelist-based HTML-sanitizing tool.',
long_description=open('README.rst').read(),
author='James Socol',
- author_email='james@mozilla.com',
+ author_email='me@jamessocol.com',
url='http://github.com/jsocol/bleach',
- license='BSD',
+ license='Apache Software License',
packages=find_packages(),
include_package_data=True,
package_data={'': ['README.rst']},
zip_safe=False,
- install_requires=['html5lib==0.95'],
+ install_requires=[
+ 'six',
+ 'html5lib>=0.999',
+ ],
classifiers=[
- 'Development Status :: 4 - Beta',
+ 'Development Status :: 5 - Production/Stable',
'Environment :: Web Environment',
'Environment :: Web Environment :: Mozilla',
'Intended Audience :: Developers',
- 'License :: OSI Approved :: BSD License',
+ 'License :: OSI Approved :: Apache Software License',
'Operating System :: OS Independent',
'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
'Topic :: Software Development :: Libraries :: Python Modules',
]
)