aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2015-12-06 13:31:51 +0000
committerChristopher Baines <mail@cbaines.net>2015-12-06 13:31:51 +0000
commit11b8160e584470439c8c0b3ab51012c9300f6788 (patch)
treedbc2728474f7c3f578e2afb8d0d74f55f2823114 /setup.py
parent6cff86ce6de27fbd4f9fc07716fb1205b14ffae4 (diff)
downloadpython-bleach-11b8160e584470439c8c0b3ab51012c9300f6788.tar
python-bleach-11b8160e584470439c8c0b3ab51012c9300f6788.tar.gz
Imported Upstream version 1.4.2upstream/1.4.2upstream
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py25
1 files changed, 20 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 6d5cfb4..e1efc93 100644
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,22 @@
from setuptools import setup, find_packages
+install_requires = [
+ 'six',
+ 'html5lib>=0.999',
+]
+
+try:
+ from collections import OrderedDict # noqa
+except ImportError:
+ # We don't use ordereddict, but html5lib does when you request
+ # alpha-sorted attributes and on Python 2.6 and it doesn't specify it
+ # as a dependency (see
+ # https://github.com/html5lib/html5lib-python/pull/177)
+ install_requires.append('ordereddict')
+
setup(
name='bleach',
- version='1.4',
+ version='1.4.2',
description='An easy whitelist-based HTML-sanitizing tool.',
long_description=open('README.rst').read(),
author='James Socol',
@@ -13,14 +27,14 @@ setup(
include_package_data=True,
package_data={'': ['README.rst']},
zip_safe=False,
- install_requires=[
- 'six',
- 'html5lib>=0.999',
+ install_requires=install_requires,
+ tests_require=[
+ 'nose>=1.3',
],
+ test_suite='nose.collector',
classifiers=[
'Development Status :: 5 - Production/Stable',
'Environment :: Web Environment',
- 'Environment :: Web Environment :: Mozilla',
'Intended Audience :: Developers',
'License :: OSI Approved :: Apache Software License',
'Operating System :: OS Independent',
@@ -31,6 +45,7 @@ setup(
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
'Topic :: Software Development :: Libraries :: Python Modules',
]
)