aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorPer Andersson <avtobiff@gmail.com>2014-02-14 01:01:33 +0100
committerPer Andersson <avtobiff@gmail.com>2014-02-14 01:01:33 +0100
commit0b3af0821fe9864e8f59729e6dbbc65949b0b0a6 (patch)
tree345fd2b50654fd544c78d86e48c93aae7062144e /debian/rules
parentc084fbcb2e2f2f167c8d65ca1ecfee406f14c24b (diff)
downloadpython-bleach-0b3af0821fe9864e8f59729e6dbbc65949b0b0a6.tar
python-bleach-0b3af0821fe9864e8f59729e6dbbc65949b0b0a6.tar.gz
Update packaging to conform to new upstream release
* Add python*-six, python*-nose, and python3-html5lib to Build-Depends. * Ship both python2 and python3 packages. * Run tests during build.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 4647c9c..e6f8559 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,10 @@
#!/usr/bin/make -f
+#export DH_VERBOSE=1
+export PYBUILD_NAME=bleach
%:
- dh $@ --with python2
+ dh $@ --with python2,python3 --buildsystem=pybuild
+
+override_dh_auto_test:
+ nosetests
+ nosetests3