aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 3035917..c7971e5 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,9 @@
+import sys
from setuptools import setup, find_packages
+if sys.version_info.major < 3:
+ raise RuntimeError('Installing requires Python 3 or newer')
+
setup(
name="prometheus-pgbouncer-exporter",
packages=find_packages(),