aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorLoïc Minier <lool@dooz.org>2008-06-27 19:37:48 +0200
committerLoïc Minier <lool@dooz.org>2008-06-27 19:37:48 +0200
commitd077e45e45ec1713b1baefdab522e7e98825cb9f (patch)
tree0aa57b580efe8904932da81f92a9c0a32523d71f /debian/rules
parentb277dbae37b8e2c89d935fd18f7808794565135d (diff)
downloadpbuilder-d077e45e45ec1713b1baefdab522e7e98825cb9f.tar
pbuilder-d077e45e45ec1713b1baefdab522e7e98825cb9f.tar.gz
Pass -s to dh_* instead of checking dpkg-architecture and using -a
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules27
1 files changed, 11 insertions, 16 deletions
diff --git a/debian/rules b/debian/rules
index b309f07..acecdef 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,8 +1,5 @@
#!/usr/bin/make -f
-# This is the debhelper compatability version to use.
-ARCH=$(shell dpkg-architecture -qDEB_HOST_ARCH)
-
build: build-stamp
build-stamp:
dh_testdir
@@ -40,20 +37,18 @@ binary-indep: build install
dh_builddeb -i
binary-arch: build install
-ifneq (,$(findstring ${ARCH},i386 amd64))
- dh_testdir -a
- dh_testroot -a
- dh_installdocs -a
+ dh_testdir -s
+ dh_testroot -s
+ dh_installdocs -s
dh_installman -ppbuilder-uml pbuilder-user-mode-linux.1 pbuilder-uml.conf.5 pdebuild-user-mode-linux.1
- dh_installchangelogs -a
- dh_link -a
- dh_compress -a -X.pdf
- dh_fixperms -a
- dh_installdeb -a
- dh_gencontrol -a
- dh_md5sums -a
- dh_builddeb -a
-endif
+ dh_installchangelogs -s
+ dh_link -s
+ dh_compress -s -X.pdf
+ dh_fixperms -s
+ dh_installdeb -s
+ dh_gencontrol -s
+ dh_md5sums -s
+ dh_builddeb -s
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install