aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authordancer <dancer>2003-03-10 11:01:01 +0000
committerdancer <dancer>2003-03-10 11:01:01 +0000
commit339ee7a89b7f9e0755090a1c764e41a4c5b172ad (patch)
tree4e81c66a4d3f14e4c58c084bf52de104281448a2 /debian/rules
parentca62e88c1fd2574426cc228aef4a1c5064dd2853 (diff)
downloadpbuilder-339ee7a89b7f9e0755090a1c764e41a4c5b172ad.tar
pbuilder-339ee7a89b7f9e0755090a1c764e41a4c5b172ad.tar.gz
+ * debian/rules: add check target for build.
+ + * Makefile (check): add check target to makefile, to see if there is + any syntax error. + + * pbuilder-updatebuildenv: support --preserve-buildplace + apply things from + Daniel Schepler <schepler@math.berkeley.edu> + + * pbuilder-satisfydepends: support --preserve-buildplace + support Format: field. + + * pbuilder-modules (pbuilder-options): support --preserve-buildplace + + * pbuilder-buildpackage (PACKAGENAME): support --preserve-buildplace + + * pbuilder-buildpackage-funcs: support --preserve-buildplace + + * pbuilder-createbuildenv (DEBOOTSTRAPSCRIPT): support --preserve-buildplace + + * pbuilder-checkparams (PRESERVE_BUILDPLACE): add PRESERVE_BUILDPLACE + + * pbuilder.8: update docs to add --preserve-buildplace +
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules1
1 files changed, 1 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 362be01..bc1d7c7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -39,6 +39,7 @@ install: build
dh_installdirs
# Add here commands to install the package into debian/build-package.
+ $(MAKE) check
$(MAKE) install DESTDIR=$(CURDIR)/debian/pbuilder
dh_movefiles -ppbuilder-uml --sourcedir=debian/pbuilder