aboutsummaryrefslogtreecommitdiff
path: root/debian/rules-uml
diff options
context:
space:
mode:
authordancer <dancer>2004-10-19 23:19:44 +0000
committerdancer <dancer>2004-10-19 23:19:44 +0000
commit98068b6f01921ac004e59303fa51bda1e22c06ac (patch)
tree39f077d8e3e9e966817f41b30707c7ba1182d595 /debian/rules-uml
parent6b8eafd5e0d10f7f2d4839f694f8ee1b61391aa9 (diff)
downloadpbuilder-98068b6f01921ac004e59303fa51bda1e22c06ac.tar
pbuilder-98068b6f01921ac004e59303fa51bda1e22c06ac.tar.gz
pbuilder-uml is removed temporarily from Debian
Diffstat (limited to 'debian/rules-uml')
-rwxr-xr-xdebian/rules-uml82
1 files changed, 82 insertions, 0 deletions
diff --git a/debian/rules-uml b/debian/rules-uml
new file mode 100755
index 0000000..6f17f09
--- /dev/null
+++ b/debian/rules-uml
@@ -0,0 +1,82 @@
+#!/usr/bin/make -f
+# This file is with UML support.
+#
+
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# This is the debhelper compatability version to use.
+export DH_COMPAT=3
+ARCH=$(shell dpkg-architecture -qDEB_HOST_ARCH)
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+
+ touch configure-stamp
+
+build: configure-stamp build-stamp
+build-stamp:
+ dh_testdir
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ -$(MAKE) clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/build-package.
+ $(MAKE) check
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/pbuilder
+ dh_movefiles -ppbuilder-uml --sourcedir=debian/pbuilder
+
+# Build architecture-independent files here.
+binary-indep: build install
+ dh_testdir -i
+ dh_testroot -i
+ dh_installdocs -i
+ dh_installman pbuilder.8 pbuilderrc.5 pdebuild.1 debuild-pbuilder.1
+ dh_installchangelogs -i
+ dh_link -i
+ dh_compress -i
+ dh_fixperms -i
+ dh_installdeb -i
+ dh_gencontrol -i
+ dh_md5sums -i
+ dh_builddeb -i
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ifeq (${ARCH},i386)
+ dh_testdir -a
+ dh_testroot -a
+ dh_installdocs -a
+ dh_installman -ppbuilder-uml pbuilder-user-mode-linux.1 pbuilder-uml.conf.5 pdebuild-user-mode-linux.1
+ dh_installchangelogs -a
+ dh_link -a
+ dh_compress -a
+ dh_fixperms -a
+ dh_installdeb -a
+ dh_gencontrol -a
+ dh_md5sums -a
+ dh_builddeb -a
+endif
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure