aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog11
-rwxr-xr-xdebian/rules7
2 files changed, 12 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index b6f397f27..ed3b8fe6e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -20,8 +20,15 @@ ikiwiki (1.34) UNRELEASED; urgency=low
* Split out a passwordauth module, that holds all the traditional password
based authentication etc code. It's enabled by default, but can be disabled
if you want only openid or some other auth method.
-
- -- Joey Hess <joeyh@debian.org> Mon, 20 Nov 2006 09:17:07 -0500
+ * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
+ * Add some code to the build system that tries to determine if the
+ lib installation directory is in @INC. If it's not, munge ikiwiki
+ to hardcode the path to the lib directory. This should allow installing
+ ikiwiki in nonstandard locations, including home directories, by just
+ setting PREFIX at build time.
+ * Fix nested examples directory in deb.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 20 Nov 2006 16:49:05 -0500
ikiwiki (1.33) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index 4e14b5ca3..9dedd3c45 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
build: build-stamp
build-stamp:
dh_testdir
- perl Makefile.PL PREFIX=/usr
+ perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor
$(MAKE)
$(MAKE) test
touch build-stamp
@@ -22,11 +22,10 @@ binary-indep: build
dh_testdir
dh_testroot
dh_clean -k
- $(MAKE) pure_install INSTALLDIRS=vendor \
- DESTDIR=$(shell pwd)/debian/ikiwiki
+ $(MAKE) pure_install DESTDIR=$(shell pwd)/debian/ikiwiki
dh_install wikilist etc/ikiwiki
dh_installdocs html
- dh_installexamples doc/examples
+ dh_installexamples doc/examples/*
dh_link usr/share/common-licenses/GPL usr/share/doc/ikiwiki/html/GPL
dh_installchangelogs
dh_compress -X html