aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL8
1 files changed, 3 insertions, 5 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 5bd1d6493..4f6b05179 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -46,11 +46,9 @@ extra_clean:
$(MAKE) -C po clean
extra_install:
- install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/templates
- $(CP) -a templates/* $(DESTDIR)$(PREFIX)/share/ikiwiki/templates
-
- install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/basewiki
- $(CP) -aL basewiki/* $(DESTDIR)$(PREFIX)/share/ikiwiki/basewiki
+ install -d $(DESTDIR)$(PREFIX)/share/ikiwiki
+ find basewiki templates \( -type f -or -type l \) ! -regex '.*\.svn.*' \
+ -exec cp --parents -aL {} $(DESTDIR)$(PREFIX)/share/ikiwiki \;
install -d $(DESTDIR)$(PREFIX)/share/man/man1
install -m 644 ikiwiki.man $(DESTDIR)$(PREFIX)/share/man/man1/ikiwiki.1