aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 5514a98ce..985c944ad 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -26,9 +26,11 @@ PROBABLE_INST_LIB=$(shell \\
tflag=$(shell if [ "$$NOTAINT" != 0 ]; then printf -- "-T"; fi)
extramodules=$(shell if [ "$$PROFILE" = 1 ]; then printf -- "-MDevel::Profiler"; fi)
-extra_build:
+ikiwiki.out: ikiwiki.in
./pm_filter $(PREFIX) $(VER) $(PROBABLE_INST_LIB) < ikiwiki.in > ikiwiki.out
chmod +x ikiwiki.out
+
+extra_build: ikiwiki.out
LANG=C perl -I. $(extramodules) $(tflag) ikiwiki.out doc html --templatedir=templates \
--underlaydir=basewiki --nousedirs\
--wikiname="ikiwiki" --verbose \