aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-04-04 17:27:48 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-04-04 17:27:48 -0400
commit8e92468eae9ac0ab8161a0c71ff6c6a0a8aef07a (patch)
tree9e26465e0ca98a5f3cbc6c72a0cace4bf83b93db /debian/rules
parent78a69e5bd632eb86ef8135e9c1d05d2c48b43362 (diff)
parent08fda4c9d374de1d3de3172a192d4d915d3dc0c1 (diff)
downloadikiwiki-8e92468eae9ac0ab8161a0c71ff6c6a0a8aef07a.tar
ikiwiki-8e92468eae9ac0ab8161a0c71ff6c6a0a8aef07a.tar.gz
Merge branch 'master'
Conflicts: doc/ikiwiki-makerepo.mdwn
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules47
1 files changed, 11 insertions, 36 deletions
diff --git a/debian/rules b/debian/rules
index 25b1f57b6..0a7ce7a26 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,44 +1,19 @@
#!/usr/bin/make -f
+%:
+ dh $@
-build: build-stamp
-build-stamp:
- dh_testdir
- perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor
- $(MAKE) -C po
- $(MAKE)
- $(MAKE) test
- touch build-stamp
+override_dh_auto_configure:
+ # keeps it out of /usr/local
+ dh_auto_configure -- PREFIX=/usr
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
- perl Makefile.PL
- if [ -e Makefile ]; then $(MAKE) realclean; fi
- dh_clean
-
-binary-arch: build
+override_dh_compress:
+ # avoid compressing files in the doc wiki
+ dh_compress -Xhtml
-binary-indep: build
- dh_testdir
- dh_testroot
- dh_clean -k
- $(MAKE) pure_install DESTDIR=$(shell pwd)/debian/ikiwiki
- dh_installdocs html
- dh_installexamples doc/examples/*
- dh_link usr/share/common-licenses/GPL-2 usr/share/doc/ikiwiki/html/GPL
- dh_installchangelogs
- dh_compress -X html
- dh_fixperms
- dh_perl
- dh_installdeb
- dh_gencontrol
- dh_md5sums
- dh_builddeb
+override_dh_auto_clean:
+ # distclean moans about MANIFEST, this is quieter
+ if [ -e Makefile ]; then $(MAKE) realclean; fi
# Not intended for use by anyone except the author.
announcedir:
@echo ${HOME}/src/ikiwiki/doc/news
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary