aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2007-12-17 19:25:44 -0500
committerJoey Hess <joey@kitenet.net>2007-12-17 19:25:44 -0500
commit67dcf175cbe6241f0dcf3564424ca178476ebdfb (patch)
tree91198940209ee45e2720152c94daa641450234a7 /debian/rules
parentbe85c0ca6d22ad4e566decab30edf494e07f51bf (diff)
downloadikiwiki-67dcf175cbe6241f0dcf3564424ca178476ebdfb.tar
ikiwiki-67dcf175cbe6241f0dcf3564424ca178476ebdfb.tar.gz
* Work around perl taint checking bug #411786, where perl sometimes randomly
sets the taint flag on untainted variables, by disabling taint checking in the deb. This sucks.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index af33131d9..ef0e7f827 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,7 +4,8 @@ build: build-stamp
build-stamp:
dh_testdir
perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor
- $(MAKE)
+ # taint checking disabled due to perl bug #411786
+ $(MAKE) NOTAINT=1
$(MAKE) test
touch build-stamp