aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2006-11-20 22:12:43 +0000
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2006-11-20 22:12:43 +0000
commit5bc73d7facbea81ae533777affaffbe3d7476c0f (patch)
tree34c96a7f781930535890a52cb0d80ddeed395caf /debian/rules
parenta95a7a428f439a08702f65da3b887382479ccaf0 (diff)
downloadikiwiki-5bc73d7facbea81ae533777affaffbe3d7476c0f.tar
ikiwiki-5bc73d7facbea81ae533777affaffbe3d7476c0f.tar.gz
* Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
* Add some code to the build system that tries to determine if the lib installation directory is in @INC. If it's not, munge ikiwiki to hardcode the path to the lib directory. This should allow installing ikiwiki in nonstandard locations, including home directories, by just setting PREFIX at build time. * Fix nested examples directory in deb.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 3 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 4e14b5ca3..9dedd3c45 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
build: build-stamp
build-stamp:
dh_testdir
- perl Makefile.PL PREFIX=/usr
+ perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor
$(MAKE)
$(MAKE) test
touch build-stamp
@@ -22,11 +22,10 @@ binary-indep: build
dh_testdir
dh_testroot
dh_clean -k
- $(MAKE) pure_install INSTALLDIRS=vendor \
- DESTDIR=$(shell pwd)/debian/ikiwiki
+ $(MAKE) pure_install DESTDIR=$(shell pwd)/debian/ikiwiki
dh_install wikilist etc/ikiwiki
dh_installdocs html
- dh_installexamples doc/examples
+ dh_installexamples doc/examples/*
dh_link usr/share/common-licenses/GPL usr/share/doc/ikiwiki/html/GPL
dh_installchangelogs
dh_compress -X html