summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a9b36dd882..d3b598d013 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9734,6 +9734,24 @@ It should enable you to implement low-level X11 applications.")
built on top of XELB.")
(license license:gpl3+)))
+(define-public emacs-exwm-next
+ (package
+ (inherit emacs-exwm)
+ (name "emacs-exwm-next")
+ (propagated-inputs
+ `(("emacs-xelb" ,emacs-xelb-next)))
+ (inputs
+ `(("xhost" ,xhost)
+ ("emacs-next" ,emacs-next)
+ ("dbus" ,dbus)))
+ (arguments
+ `(,@(package-arguments emacs-exwm)
+ #:emacs ,emacs-next))
+ (home-page "https://github.com/ch11ng/exwm")
+ (description "EXWM is a full-featured tiling X window manager for Emacs
+built on top of XELB.")
+ (license license:gpl3+)))
+
(define-public emacs-switch-window
(package
(name "emacs-switch-window")