summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordakling <dario.klingenberg@web.de>2020-02-26 22:07:44 +0100
committerGuix Patches Tester <>2020-02-28 09:55:12 +0000
commit267665ab01c801638a3191eef112f90ad5bc2b0c (patch)
treeb9cc4f12a588c2bcbbc000c707f5aaa6421f1baa
parenta954dc57f2b642b3873732128012b537cc22abb3 (diff)
downloadpatches-series-3041.tar
patches-series-3041.tar.gz
gnu: Add emacs-exwm-next.series-3041
* gnu/packages/emacs-xyz.scm (emacs-exwm-next): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a9b36dd882..d3b598d013 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9734,6 +9734,24 @@ It should enable you to implement low-level X11 applications.")
built on top of XELB.")
(license license:gpl3+)))
+(define-public emacs-exwm-next
+ (package
+ (inherit emacs-exwm)
+ (name "emacs-exwm-next")
+ (propagated-inputs
+ `(("emacs-xelb" ,emacs-xelb-next)))
+ (inputs
+ `(("xhost" ,xhost)
+ ("emacs-next" ,emacs-next)
+ ("dbus" ,dbus)))
+ (arguments
+ `(,@(package-arguments emacs-exwm)
+ #:emacs ,emacs-next))
+ (home-page "https://github.com/ch11ng/exwm")
+ (description "EXWM is a full-featured tiling X window manager for Emacs
+built on top of XELB.")
+ (license license:gpl3+)))
+
(define-public emacs-switch-window
(package
(name "emacs-switch-window")